aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/openssl/Makefile8
-rw-r--r--security/openssl/distinfo8
-rw-r--r--security/openssl/files-beta/patch-CAN-2005-296928
-rw-r--r--security/openssl/files/patch-CAN-2005-296928
4 files changed, 8 insertions, 64 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 9e56a7990d62..f17ba6c31da5 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -11,11 +11,11 @@ PORTVERSION= 0.9.8
PORTREVISION!= date -v-1d +%Y%m%d
.else
.if !defined(WITH_OPENSSL_BETA) && defined(WITH_OPENSSL_097)
-PORTVERSION= 0.9.7g
-PORTREVISION?= 1
+PORTVERSION= 0.9.7h
+PORTREVISION?= 0
.else
-PORTVERSION= 0.9.8
-PORTREVISION?= 2
+PORTVERSION= 0.9.8a
+PORTREVISION?= 0
.endif
.endif
CATEGORIES= security devel
diff --git a/security/openssl/distinfo b/security/openssl/distinfo
index 053e90919874..a3589ff62d0b 100644
--- a/security/openssl/distinfo
+++ b/security/openssl/distinfo
@@ -1,4 +1,4 @@
-MD5 (openssl-0.9.7g.tar.gz) = 991615f73338a571b6a1be7d74906934
-SIZE (openssl-0.9.7g.tar.gz) = 3132217
-MD5 (openssl-0.9.8.tar.gz) = 9da21071596a124acde6080552deac16
-SIZE (openssl-0.9.8.tar.gz) = 3259550
+MD5 (openssl-0.9.7h.tar.gz) = 8dc90a113eb8925795071fbe52b2932c
+SIZE (openssl-0.9.7h.tar.gz) = 3287019
+MD5 (openssl-0.9.8a.tar.gz) = 1d16c727c10185e4d694f87f5e424ee1
+SIZE (openssl-0.9.8a.tar.gz) = 3271435
diff --git a/security/openssl/files-beta/patch-CAN-2005-2969 b/security/openssl/files-beta/patch-CAN-2005-2969
deleted file mode 100644
index 32a6230b3e48..000000000000
--- a/security/openssl/files-beta/patch-CAN-2005-2969
+++ /dev/null
@@ -1,28 +0,0 @@
-Index: crypto/openssl/ssl/s23_srvr.c
-===================================================================
-RCS file: /home/ncvs/src/crypto/openssl/ssl/s23_srvr.c,v
-retrieving revision 1.7
-diff -u -p -r1.7 s23_srvr.c
---- ssl/s23_srvr.c 28 Jan 2003 22:34:21 -0000 1.7
-+++ ssl/s23_srvr.c 10 Oct 2005 16:39:19 -0000
-@@ -268,9 +268,6 @@ int ssl23_get_client_hello(SSL *s)
- int n=0,j;
- int type=0;
- int v[2];
--#ifndef OPENSSL_NO_RSA
-- int use_sslv2_strong=0;
--#endif
-
- if (s->state == SSL23_ST_SR_CLNT_HELLO_A)
- {
-@@ -519,9 +516,7 @@ int ssl23_get_client_hello(SSL *s)
- }
-
- s->state=SSL2_ST_GET_CLIENT_HELLO_A;
-- if ((s->options & SSL_OP_MSIE_SSLV2_RSA_PADDING) ||
-- use_sslv2_strong ||
-- (s->options & SSL_OP_NO_TLSv1 && s->options & SSL_OP_NO_SSLv3))
-+ if (s->options & SSL_OP_NO_TLSv1 && s->options & SSL_OP_NO_SSLv3)
- s->s2->ssl2_rollback=0;
- else
- /* reject SSL 2.0 session if client supports SSL 3.0 or TLS 1.0
diff --git a/security/openssl/files/patch-CAN-2005-2969 b/security/openssl/files/patch-CAN-2005-2969
deleted file mode 100644
index 32a6230b3e48..000000000000
--- a/security/openssl/files/patch-CAN-2005-2969
+++ /dev/null
@@ -1,28 +0,0 @@
-Index: crypto/openssl/ssl/s23_srvr.c
-===================================================================
-RCS file: /home/ncvs/src/crypto/openssl/ssl/s23_srvr.c,v
-retrieving revision 1.7
-diff -u -p -r1.7 s23_srvr.c
---- ssl/s23_srvr.c 28 Jan 2003 22:34:21 -0000 1.7
-+++ ssl/s23_srvr.c 10 Oct 2005 16:39:19 -0000
-@@ -268,9 +268,6 @@ int ssl23_get_client_hello(SSL *s)
- int n=0,j;
- int type=0;
- int v[2];
--#ifndef OPENSSL_NO_RSA
-- int use_sslv2_strong=0;
--#endif
-
- if (s->state == SSL23_ST_SR_CLNT_HELLO_A)
- {
-@@ -519,9 +516,7 @@ int ssl23_get_client_hello(SSL *s)
- }
-
- s->state=SSL2_ST_GET_CLIENT_HELLO_A;
-- if ((s->options & SSL_OP_MSIE_SSLV2_RSA_PADDING) ||
-- use_sslv2_strong ||
-- (s->options & SSL_OP_NO_TLSv1 && s->options & SSL_OP_NO_SSLv3))
-+ if (s->options & SSL_OP_NO_TLSv1 && s->options & SSL_OP_NO_SSLv3)
- s->s2->ssl2_rollback=0;
- else
- /* reject SSL 2.0 session if client supports SSL 3.0 or TLS 1.0