aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/libparanoia/Makefile8
-rw-r--r--security/libparanoia/files/patch-stentry.c10
2 files changed, 7 insertions, 11 deletions
diff --git a/security/libparanoia/Makefile b/security/libparanoia/Makefile
index 62b984054293..48801644277a 100644
--- a/security/libparanoia/Makefile
+++ b/security/libparanoia/Makefile
@@ -6,7 +6,7 @@
PORTNAME= libparanoia
PORTVERSION= 1.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/snar/
@@ -14,6 +14,7 @@ MAINTAINER= snar@paranoia.ru
COMMENT= Safe (in the mean of stack smashing) reincarnation of strcpy et al
ONLY_FOR_ARCHS= i386
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
@@ -27,6 +28,11 @@ BROKEN= You need to have libc sources installed in /usr/src/lib/libc \
.include <bsd.port.pre.mk>
+pre-patch:
+ @${REINPLACE_CMD} -e 's|\(SIGSEGV\),\(getpid()\)|\2,\1|; \
+ s|#include <varargs.h>||' \
+ ${WRKSRC}/stentry.c
+
.if ${OSVERSION} >= 500039
post-patch:
@(cd ${_DISTDIR};${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/vsnprintf-current.patch)
diff --git a/security/libparanoia/files/patch-stentry.c b/security/libparanoia/files/patch-stentry.c
deleted file mode 100644
index 4db893c47a87..000000000000
--- a/security/libparanoia/files/patch-stentry.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- stentry.c.orig Tue Nov 4 01:27:18 2003
-+++ stentry.c Tue Nov 4 01:27:23 2003
-@@ -2,7 +2,6 @@
- #include <signal.h>
- #include <stdio.h>
- #include <syslog.h>
--#include <varargs.h>
- #include <string.h>
-
- static unsigned long save[10];