aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-flask-saml/Makefile24
-rw-r--r--security/py-flask-saml/distinfo3
-rw-r--r--security/py-flask-saml/files/patch-setup.py10
-rw-r--r--security/py-flask-saml/pkg-descr4
5 files changed, 42 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3ae337f5f977..9976d6599983 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -935,6 +935,7 @@
SUBDIR += py-first-server
SUBDIR += py-flask-httpauth
SUBDIR += py-flask-kerberos
+ SUBDIR += py-flask-saml
SUBDIR += py-gixy
SUBDIR += py-gnupg
SUBDIR += py-gnutls
diff --git a/security/py-flask-saml/Makefile b/security/py-flask-saml/Makefile
new file mode 100644
index 000000000000..0e4ddb37cd4f
--- /dev/null
+++ b/security/py-flask-saml/Makefile
@@ -0,0 +1,24 @@
+# Created by: John W. O'Brien <john@saltant.com>
+# $FreeBSD$
+
+PORTNAME= Flask-SAML
+PORTVERSION= 0.4.3
+CATEGORIES= security www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= john@saltant.com
+COMMENT= SAML authentication for Flask web apps
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>0.8.0:www/py-flask@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}blinker>=1.1:devel/py-blinker@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pysaml2>4.0.0:security/py-pysaml2@${FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-flask-saml/distinfo b/security/py-flask-saml/distinfo
new file mode 100644
index 000000000000..367573e99495
--- /dev/null
+++ b/security/py-flask-saml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1516061025
+SHA256 (Flask-SAML-0.4.3.tar.gz) = f03dea7bee6746de22042a2f73637d39666e54ab15e3d844de134603f92861c1
+SIZE (Flask-SAML-0.4.3.tar.gz) = 4572
diff --git a/security/py-flask-saml/files/patch-setup.py b/security/py-flask-saml/files/patch-setup.py
new file mode 100644
index 000000000000..20ea55a0d425
--- /dev/null
+++ b/security/py-flask-saml/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2018-05-21 01:06:59 UTC
++++ setup.py
+@@ -25,7 +25,6 @@ setuptools.setup(
+ author='Florian Ruechel',
+ tests_require=['pytest >= 2.5.2', 'mock', 'sphinx', 'pytest-mock'],
+ install_requires=install_requires,
+- setup_requires=['pytest-runner'],
+ author_email='fruechel@atlassian.com',
+ description='Flask SAML integration',
+ long_description=long_description,
diff --git a/security/py-flask-saml/pkg-descr b/security/py-flask-saml/pkg-descr
new file mode 100644
index 000000000000..e14b18b0cf6c
--- /dev/null
+++ b/security/py-flask-saml/pkg-descr
@@ -0,0 +1,4 @@
+Flask-SAML is an extension for the Flask web application micro framework
+that implements Security Association Markup Language (SAML) authentication.
+
+WWW: https://bitbucket.org/asecurityteam/flask_saml