aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/hotssh/Makefile8
-rw-r--r--security/hotssh/files/patch-hotssh_hotvte_vteterm.py14
2 files changed, 18 insertions, 4 deletions
diff --git a/security/hotssh/Makefile b/security/hotssh/Makefile
index 06906923c9b8..0ab7440df09a 100644
--- a/security/hotssh/Makefile
+++ b/security/hotssh/Makefile
@@ -7,9 +7,9 @@
PORTNAME= hotssh
PORTVERSION= 0.2.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
MAINTAINER= ashish@FreeBSD.org
@@ -18,11 +18,11 @@ COMMENT= HotSSH is an interface to Secure Shell, for GNOME and OpenSSH
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject \
${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
- ${PYTHON_SITELIBDIR}/pysqlite2/test/__init__.py:${PORTSDIR}/databases/py-pysqlite23 \
+ ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject \
- ${PYTHON_SITELIBDIR}/pysqlite2/test/__init__.py:${PORTSDIR}/databases/py-pysqlite23 \
+ ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte
USE_GNOME= pygtk2 gnomedocutils libxslt glib20
diff --git a/security/hotssh/files/patch-hotssh_hotvte_vteterm.py b/security/hotssh/files/patch-hotssh_hotvte_vteterm.py
new file mode 100644
index 000000000000..cb274cd2b9b9
--- /dev/null
+++ b/security/hotssh/files/patch-hotssh_hotvte_vteterm.py
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- hotssh/hotvte/vteterm.py.orig
++++ hotssh/hotvte/vteterm.py
+@@ -264,7 +264,7 @@
+ def __set_gtk_colors(self):
+ fg = self.style.text[gtk.STATE_NORMAL]
+ bg = self.style.base[gtk.STATE_NORMAL]
+- self.set_colors(True, fg, bg, isdefault=True)
++ self.set_colors(fg, bg, False, isdefault=True)
+
+ def set_colors(self, fg, bg, palette, isdefault=False):
+ if not isdefault:
an class='insertions'>+1 * SIZEify (maintainer timeout)trevor2004-03-31