aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/hs-Crypto/Makefile24
-rw-r--r--security/hs-Crypto/distinfo2
-rw-r--r--security/hs-Crypto/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 7ef1ddc86360..5a9be7c16abb 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -187,6 +187,7 @@
SUBDIR += honggfuzz
SUBDIR += horde-jeta
SUBDIR += hotssh
+ SUBDIR += hs-Crypto
SUBDIR += hs-SHA
SUBDIR += hs-digest
SUBDIR += httprint
diff --git a/security/hs-Crypto/Makefile b/security/hs-Crypto/Makefile
new file mode 100644
index 000000000000..945e335ee7d3
--- /dev/null
+++ b/security/hs-Crypto/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: hs-Crypto
+# Date created: July 5, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypto
+PORTVERSION= 4.2.3
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Collects together existing Haskell cryptographic functions
+
+FILE_LICENSE= ReadMe.tex
+
+USE_CABAL= QuickCheck>=2.4.0.1 HUnit
+CABAL_SETUP= Setup.hs
+
+EXECUTABLE= HMACTest QuickTest RSATest SHA1Test SymmetricTest WordListTest
+PORTDATA= *
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-Crypto/distinfo b/security/hs-Crypto/distinfo
new file mode 100644
index 000000000000..563c233cc885
--- /dev/null
+++ b/security/hs-Crypto/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/Crypto-4.2.3.tar.gz) = 7909f4deae9478c234c717a7ff5bd6683ccbf6a199b28d6463281e113d45910b
+SIZE (cabal/Crypto-4.2.3.tar.gz) = 56913
diff --git a/security/hs-Crypto/pkg-descr b/security/hs-Crypto/pkg-descr
new file mode 100644
index 000000000000..55c7064eaa62
--- /dev/null
+++ b/security/hs-Crypto/pkg-descr
@@ -0,0 +1,6 @@
+DES, Blowfish, AES, TEA, SHA1, MD5, RSA, BubbleBabble, Hexdump, Support for
+Word128, Word192 and Word256 and Beyond, PKCS5 Padding, Various Encryption
+Modes e.g. Cipher Block Chaining all in one package, with HUnit and
+QuickCheck tests, and examples.
+
+WWW: http://hackage.haskell.org/package/Crypto