aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/mhash/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/security/mhash/Makefile b/security/mhash/Makefile
index b10315d79d67..5220ed384c88 100644
--- a/security/mhash/Makefile
+++ b/security/mhash/Makefile
@@ -13,18 +13,18 @@ COMMENT= Easy-to-use library for strong hashes such as MD5 and SHA1
LICENSE= LGPL20 # or later
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= tar:bzip2 libtool
+USES= libtool tar:bzip2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-static --with-gnu-ld
+TEST_TARGET= check
PORTDOCS= example.c skid2-authentication
-test: build
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmhash.so
+
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${DOCSDIR}