aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/bdc/Makefile2
-rw-r--r--security/ca_root_nss/Makefile2
-rw-r--r--security/courier-authlib/Makefile2
-rw-r--r--security/doorman/Makefile2
-rw-r--r--security/hamachi/Makefile2
-rw-r--r--security/ipsec-tools/Makefile2
-rw-r--r--security/libgcrypt/Makefile2
-rw-r--r--security/libressl-devel/Makefile4
-rw-r--r--security/libressl/Makefile4
-rw-r--r--security/nacl/Makefile2
-rw-r--r--security/nmap/Makefile2
-rw-r--r--security/openssl/Makefile2
-rw-r--r--security/openvpn-auth-ldap/Makefile4
-rw-r--r--security/p5-Authen-TypeKey/Makefile2
-rw-r--r--security/p5-Crypt-OpenPGP/Makefile2
-rw-r--r--security/p5-openxpki/Makefile2
-rw-r--r--security/pgp/Makefile2
-rw-r--r--security/shishi/Makefile2
-rw-r--r--security/sks/Makefile2
-rw-r--r--security/spike-proxy/Makefile2
-rw-r--r--security/vuxml/Makefile2
21 files changed, 24 insertions, 24 deletions
diff --git a/security/bdc/Makefile b/security/bdc/Makefile
index 8766a8dcc9e6..6f528ffd66a8 100644
--- a/security/bdc/Makefile
+++ b/security/bdc/Makefile
@@ -47,7 +47,7 @@ do-install:
${MV} ${STAGEDIR}${PREFIX}/bdc/doc ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${STAGEDIR}${PREFIX}/bdc/man/bdc.1 ${STAGEDIR}${MANPREFIX}/man/man1
- ${RM} -f ${STAGEDIR}${PREFIX}/bdc/man
+ ${RM} ${STAGEDIR}${PREFIX}/bdc/man
${INSTALL_SCRIPT} ${WRKDIR}/bdc ${STAGEDIR}${PREFIX}/bin
diff --git a/security/ca_root_nss/Makefile b/security/ca_root_nss/Makefile
index f55873d26d9d..e182753f9792 100644
--- a/security/ca_root_nss/Makefile
+++ b/security/ca_root_nss/Makefile
@@ -47,7 +47,7 @@ do-extract:
@${TAR} -C ${WRKDIR} -xf ${DISTDIR}/nss-${VERSION_NSS}${NSS_SUFFIX}${EXTRACT_SUFX} \
${CERTDATA_TXT_PATH}
@${CP} ${WRKDIR}/${CERTDATA_TXT_PATH} ${WRKDIR}
- @${RM} -rf ${WRKDIR}/nss-${VERSION_NSS}
+ @${RM} -r ${WRKDIR}/nss-${VERSION_NSS}
do-build: apply-slist
@${SETENV} PATH=${LOCALBASE}/bin:$${PATH} \
diff --git a/security/courier-authlib/Makefile b/security/courier-authlib/Makefile
index 07e75cdd2505..43447db915d4 100644
--- a/security/courier-authlib/Makefile
+++ b/security/courier-authlib/Makefile
@@ -179,7 +179,7 @@ post-patch:
pre-configure:
@if [ -f "${WRKDIR}/courier-authlib.cache" -a -s "${WRKDIR}/courier-authlib.cache" ] ; then \
- ${RM} -f "${WRKDIR}/courier-authlib.cache" ; \
+ ${RM} "${WRKDIR}/courier-authlib.cache" ; \
fi
post-install:
diff --git a/security/doorman/Makefile b/security/doorman/Makefile
index f7e42abde40b..7ae1bb51893e 100644
--- a/security/doorman/Makefile
+++ b/security/doorman/Makefile
@@ -32,7 +32,7 @@ pre-patch:
${WRKSRC}/doormand.c
post-install:
- ${RM} -f ${STAGEDIR}${PREFIX}/etc/doormand/ipf_add
+ ${RM} ${STAGEDIR}${PREFIX}/etc/doormand/ipf_add
(cd ${FILESDIR} && ${INSTALL_SCRIPT} ipf_add.atend ipf_delete \
ipf_add.before_block ${STAGEDIR}${PREFIX}/etc/doormand)
${INSTALL_DATA} ${WRKDIR}/doormand.cf.EXAMPLE \
diff --git a/security/hamachi/Makefile b/security/hamachi/Makefile
index 87ed335d1384..e8e8319870b2 100644
--- a/security/hamachi/Makefile
+++ b/security/hamachi/Makefile
@@ -22,7 +22,7 @@ PORTDOCS= README CHANGES
MAKE_ENV= HAMACHI_DST=${STAGEDIR}${PREFIX}/bin TUNCFG_DST=${STAGEDIR}${PREFIX}/sbin
post-patch:
- ${RM} -f ${WRKSRC}/tuncfg/tuncfg
+ ${RM} ${WRKSRC}/tuncfg/tuncfg
${LOCALBASE}/bin/upx -d ${WRKSRC}/hamachi
do-build:
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index 781eb36c79af..8d59a62db2f1 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -92,7 +92,7 @@ post-install:
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}/${EXAMPLESDIR}
- @${RM} -f ${WRKSRC}/src/racoon/samples/*.in
+ @${RM} ${WRKSRC}/src/racoon/samples/*.in
@${CP} -r ${WRKSRC}/src/racoon/samples/* ${STAGEDIR}/${EXAMPLESDIR}
post-install-DOCS-on:
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index 63dd6d02aa8f..878480ed653d 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -38,7 +38,7 @@ CONFIGURE_ARGS+= --disable-asm
.endif
post-patch:
- ${RM} -f ${WRKSRC}/doc/gcrypt.info*
+ ${RM} ${WRKSRC}/doc/gcrypt.info*
${REINPLACE_CMD} -e 's|ALIGN (3)|ALIGN (2)|g' ${WRKSRC}/mpi/i386/*.S
post-install:
diff --git a/security/libressl-devel/Makefile b/security/libressl-devel/Makefile
index 0fbc68ed3a65..2cde312b6a3e 100644
--- a/security/libressl-devel/Makefile
+++ b/security/libressl-devel/Makefile
@@ -38,10 +38,10 @@ post-stage-NC-on:
${INSTALL_MAN} ${WRKSRC}/apps/nc/nc.1 ${STAGEDIR}/${PREFIX}/man/man1/nc.1
post-stage:
- ${RM} -rf ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem
+ ${RM} -r ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem
post-install-MAN3-off:
- ${RM} -rf ${STAGEDIR}/${PREFIX}/man/man3
+ ${RM} -r ${STAGEDIR}/${PREFIX}/man/man3
${REINPLACE_CMD} -e '/^man\/man3/d' ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index 8447257ffc26..15c68cae204f 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -37,10 +37,10 @@ post-stage-NC-on:
${INSTALL_MAN} ${WRKSRC}/apps/nc/nc.1 ${STAGEDIR}/${PREFIX}/man/man1/nc.1
post-stage:
- ${RM} -rf ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem
+ ${RM} -r ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem
post-install-MAN3-off:
- ${RM} -rf ${STAGEDIR}/${PREFIX}/man/man3
+ ${RM} -r ${STAGEDIR}/${PREFIX}/man/man3
${REINPLACE_CMD} -e '/^man\/man3/d' ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/security/nacl/Makefile b/security/nacl/Makefile
index 2efca4bcf203..a3897b9eefaa 100644
--- a/security/nacl/Makefile
+++ b/security/nacl/Makefile
@@ -30,7 +30,7 @@ post-patch:
@${REINPLACE_CMD} -i -e "s|c++|${CXX}|" ${WRKSRC}/okcompilers/cpp
pre-build:
- ${RM} -rf ${WRKSRC}/crypto_onetimeauth/poly1305/amd64
+ ${RM} -r ${WRKSRC}/crypto_onetimeauth/poly1305/amd64
do-build:
cd ${WRKSRC} && ./do
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index e509561afd92..962746081909 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -47,7 +47,7 @@ CONFIGURE_ARGS+=--without-localdirs \
# XXX limit results if we do a grep in the sources!
post-extract:
- @${RM} -rf ${WRKSRC}/mswin32
+ @${RM} -r ${WRKSRC}/mswin32
post-configure:
@${REINPLACE_CMD} -e "s|^DESTDIR *=|& ${DESTDIR}|" ${WRKSRC}/Makefile
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 9df343a05971..1d688fd29978 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -130,7 +130,7 @@ post-patch:
post-patch-MAN3-off:
${GREP} -L openssl_manual_section ${WRKSRC}/doc/crypto/*.pod | ${XARGS} ${RM}
- ${RM} -rf ${WRKSRC}/doc/ssl/*.pod
+ ${RM} -r ${WRKSRC}/doc/ssl/*.pod
${REINPLACE_CMD} -e 's|pod doc/ssl/\*\.pod|pod|' ${WRKSRC}/Makefile.org
do-configure:
diff --git a/security/openvpn-auth-ldap/Makefile b/security/openvpn-auth-ldap/Makefile
index 70bef88ef51f..1715350187b2 100644
--- a/security/openvpn-auth-ldap/Makefile
+++ b/security/openvpn-auth-ldap/Makefile
@@ -63,11 +63,11 @@ CC+= ${DEBUG_FLAGS}
# Note that googlecode.com is gone.
build-tarball: ${DISTFILES}
${DISTFILES}:
- ${RM} -rf ${WRKSRC}
+ ${RM} -r ${WRKSRC}
svn export -r${PORTVERSION:E:C/^s//} \
http://openvpn-auth-ldap.googlecode.com/svn/trunk/ ${WRKSRC}
tar -C ${WRKSRC}/.. -cvf - ${WRKSRC:T} | ${XZ_CMD} -vvc >${DISTFILES} || \
- { ${RM} -f ${DISTFILES} ; exit 1 ; }
+ { ${RM} ${DISTFILES} ; exit 1 ; }
upload-tarball: build-tarball
scp ${DISTFILES} freefall.freebsd.org:public_distfiles/
diff --git a/security/p5-Authen-TypeKey/Makefile b/security/p5-Authen-TypeKey/Makefile
index ed3ac976482c..759f4b5f7f21 100644
--- a/security/p5-Authen-TypeKey/Makefile
+++ b/security/p5-Authen-TypeKey/Makefile
@@ -26,6 +26,6 @@ USES= perl5
post-patch:
# Really old M::I code
- ${RM} -rf ${WRKSRC}/inc
+ ${RM} -r ${WRKSRC}/inc
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenPGP/Makefile b/security/p5-Crypt-OpenPGP/Makefile
index f47f6386531d..3a21ef0cd896 100644
--- a/security/p5-Crypt-OpenPGP/Makefile
+++ b/security/p5-Crypt-OpenPGP/Makefile
@@ -31,6 +31,6 @@ USES= perl5
USE_PERL5= configure
post-patch:
- @${RM} -f ${WRKSRC}/lib/Crypt/OpenPGP/Ciphertext.pm.orig
+ @${RM} ${WRKSRC}/lib/Crypt/OpenPGP/Ciphertext.pm.orig
.include <bsd.port.mk>
diff --git a/security/p5-openxpki/Makefile b/security/p5-openxpki/Makefile
index fadef7561c03..af9d078baca3 100644
--- a/security/p5-openxpki/Makefile
+++ b/security/p5-openxpki/Makefile
@@ -103,7 +103,7 @@ post-patch:
${CAT} filelist | ${XARGS} -0 -I % ${REINPLACE_CMD} -e 's|/etc/openxpki|${PREFIX}/etc/openxpki|g' "%"; \
${CAT} filelist | ${XARGS} -0 -I % ${REINPLACE_CMD} -e 's|/var/run/openxpkid.pid|/var/openxpki/openxpkid.pid|g' "%"; \
${CAT} filelist | ${XARGS} -0 -I % ${REINPLACE_CMD} -e 's|/var/openxpki/\([^\.]*\)\.log|/var/log/openxpki/\1\.log|g' "%"; \
- ${CAT} filelist | ${XARGS} -0 -I % ${RM} -f "%.bak"; \
+ ${CAT} filelist | ${XARGS} -0 -I % ${RM} "%.bak"; \
${RM} filelist; \
)
@${MKDIR} ${WRKSRC}/t/var/log/openxpki
diff --git a/security/pgp/Makefile b/security/pgp/Makefile
index 42892c0bbdd9..3d2e654cc724 100644
--- a/security/pgp/Makefile
+++ b/security/pgp/Makefile
@@ -22,7 +22,7 @@ PGPLIB= ${STAGEDIR}${PREFIX}/share/pgp
post-extract:
cd ${WRKDIR}; ${TAR} -xf pgp263ii.tar; \
- ${RM} -f pgp263ii.tar
+ ${RM} pgp263ii.tar
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pgp ${STAGEDIR}${PREFIX}/bin/
diff --git a/security/shishi/Makefile b/security/shishi/Makefile
index b32fcf793f18..b9cf1413e809 100644
--- a/security/shishi/Makefile
+++ b/security/shishi/Makefile
@@ -35,7 +35,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
post-extract:
- @${RM} -f ${WRKSRC}/doc/shishi.info*
+ @${RM} ${WRKSRC}/doc/shishi.info*
@cd ${WRKSRC}/db/gl && ${LN} -s ../../build-aux/link-warning.h
post-patch:
diff --git a/security/sks/Makefile b/security/sks/Makefile
index b66f0a476060..120a682f36c6 100644
--- a/security/sks/Makefile
+++ b/security/sks/Makefile
@@ -30,7 +30,7 @@ OPTIONS_DEFINE= DOCS
post-extract:
@: > ${WRKSRC}/Makefile.local
@${REINPLACE_CMD} 's/-ccopt -pg //' ${WRKSRC}/Makefile
- @cd ${WRKSRC} && ${RM} -f .depend
+ @cd ${WRKSRC} && ${RM} .depend
post-patch:
@${REINPLACE_CMD} -Ee '/^CC=/d; /^CFLAGS=/s/=/+=/' \
diff --git a/security/spike-proxy/Makefile b/security/spike-proxy/Makefile
index 95a9e1dca230..c7a83ce184c6 100644
--- a/security/spike-proxy/Makefile
+++ b/security/spike-proxy/Makefile
@@ -26,7 +26,7 @@ OPTIONS_DEFINE= DOCS
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
- @${RM} -rf ${WRKSRC}/*.bak
+ @${RM} -r ${WRKSRC}/*.bak
${CP} -Rp ${WRKSRC}/* ${STAGEDIR}${DATADIR}
${SED} "s|DATADIR|${DATADIR}|" ${SCRIPTDIR}/spkproxy.sh > \
${STAGEDIR}${PREFIX}/bin/spkproxy.sh
diff --git a/security/vuxml/Makefile b/security/vuxml/Makefile
index d8a73fac3c1f..1f07767e1d0e 100644
--- a/security/vuxml/Makefile
+++ b/security/vuxml/Makefile
@@ -33,7 +33,7 @@ dir_DTD= share/xml/dtd/vuxml
VUXML_FILE?= ${PKGDIR}/vuln.xml
do-extract:
- @${RM} -rf ${WRKDIR}
+ @${RM} -r ${WRKDIR}
@${MKDIR} ${WRKDIR}
.for f in ${DISTFILES}
${CP} ${_DISTDIR}/${f} ${WRKDIR}/${f}