aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rainbowcrack/Makefile33
-rw-r--r--security/rainbowcrack/distinfo3
-rw-r--r--security/rainbowcrack/pkg-descr13
-rw-r--r--security/rainbowcrack/pkg-plist6
5 files changed, 56 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4866e5a5e316..289c24d6da9d 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -525,6 +525,7 @@
SUBDIR += racoon2
SUBDIR += radiusniff
SUBDIR += rain
+ SUBDIR += rainbowcrack
SUBDIR += rats
SUBDIR += rc5pipe
SUBDIR += rdigest
diff --git a/security/rainbowcrack/Makefile b/security/rainbowcrack/Makefile
new file mode 100644
index 000000000000..d8548e42604e
--- /dev/null
+++ b/security/rainbowcrack/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: rainbowcrack
+# Date created: 8 May 2006
+# Whom: bryan@freshdns.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= rainbowcrack
+PORTVERSION= 1.2
+CATEGORIES= security
+MASTER_SITES= http://freshdns.net/rainbowcrack/
+
+MAINTAINER= bryan@freshdns.net
+COMMENT= Hash cracker that precomputes plaintext - ciphertext pairs in advance
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not build on 4.x
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|g++|$$(CXX) $$(CXXFLAGS)|; s|\-O3||' \
+ ${WRKSRC}/${MAKEFILE}
+
+do-install:
+.for f in rcrack rtgen rtdump rtsort
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/charset.txt ${EXAMPLESDIR}
+
+.include <bsd.port.post.mk>
diff --git a/security/rainbowcrack/distinfo b/security/rainbowcrack/distinfo
new file mode 100644
index 000000000000..a6ca6e81e22c
--- /dev/null
+++ b/security/rainbowcrack/distinfo
@@ -0,0 +1,3 @@
+MD5 (rainbowcrack-1.2.tar.gz) = bf806a618206147d83d26a7e162acfe1
+SHA256 (rainbowcrack-1.2.tar.gz) = d035cb12c0f762fac78f617dea246c5cf4b7503c3b173c3871663eaa3f02b6b4
+SIZE (rainbowcrack-1.2.tar.gz) = 16215
diff --git a/security/rainbowcrack/pkg-descr b/security/rainbowcrack/pkg-descr
new file mode 100644
index 000000000000..32a9755b9ce4
--- /dev/null
+++ b/security/rainbowcrack/pkg-descr
@@ -0,0 +1,13 @@
+RainbowCrack is a general propose implementation of Philippe Oechslin's faster
+time-memory trade-off technique.
+
+In short, the RainbowCrack tool is a hash cracker. A traditional brute force
+cracker tries all possible plaintexts one by one in cracking time. It is time
+consuming to break complex passwords this way. The idea of time-memory trade-off
+is to do all cracking time computation in advance and store the result in files
+so called "rainbow table". It does take a long time to precompute the tables.
+But once the one time precomputation is finished, a time-memory trade-off
+cracker can be hundreds of times faster than a brute force cracker, with the
+help of precomputed tables.
+
+WWW: http://www.antsight.com/zsl/rainbowcrack/
diff --git a/security/rainbowcrack/pkg-plist b/security/rainbowcrack/pkg-plist
new file mode 100644
index 000000000000..7301f80ee5d9
--- /dev/null
+++ b/security/rainbowcrack/pkg-plist
@@ -0,0 +1,6 @@
+bin/rcrack
+bin/rtgen
+bin/rtdump
+bin/rtsort
+%%EXAMPLESDIR%%/charset.txt
+@dirrm %%EXAMPLESDIR%%