aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash
diff options
context:
space:
mode:
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 32dff6b99482..2393c82f1f86 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -34,7 +34,11 @@ COMMENT= The GNU Bourne Again Shell
WRKSRC= ${WRKDIR}/bash-${PORTVERSION:C/\....$//}
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
+.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT)
CONFIGURE_ENV= LDFLAGS=-static
+.else
+CONFIGURE_ARGS+= --enable-static-link=no
+.endif
MAN1= bash.1 bashbug.1
.if defined(WITH_NET_REDIRECTIONS)