aboutsummaryrefslogtreecommitdiffstats
path: root/shells/dash/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/dash/Makefile')
-rw-r--r--shells/dash/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/shells/dash/Makefile b/shells/dash/Makefile
new file mode 100644
index 000000000000..c204e191cde6
--- /dev/null
+++ b/shells/dash/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: dash
+# Date created: Nov 10, 2009
+# Whom: Eitan Adler
+#
+# $FreeBSD$
+#
+
+PORTNAME= dash
+PORTVERSION= 0.5.5.1
+CATEGORIES= shells
+MASTER_SITES= http://gondor.apana.org.au/~herbert/dash/files/
+
+MAINTAINER= EitanAdlerList@gmail.com
+COMMENT= A POSIX-compliant implementation of /bin/sh
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CFLAGS+= -DUNUSABLE_RT_SIGNALS
+
+PLIST_FILES= bin/dash
+MAN1= dash.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '/COMMON_CFLAGS =/ s|$$| ${CFLAGS}|' \
+ ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>