aboutsummaryrefslogtreecommitdiffstats
path: root/shells/p5-Term-ShellUI/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/p5-Term-ShellUI/Makefile')
-rw-r--r--shells/p5-Term-ShellUI/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/shells/p5-Term-ShellUI/Makefile b/shells/p5-Term-ShellUI/Makefile
index e2edd0648afe..ede49850b792 100644
--- a/shells/p5-Term-ShellUI/Makefile
+++ b/shells/p5-Term-ShellUI/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Term-ShellUI
-PORTVERSION= 0.91
+PORTVERSION= 0.92
CATEGORIES= shells perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A fully-featured shell-like command line environment
-RUN_DEPENDS= ${SITE_PERL}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
+BUILD_DEPENDS= p5-ReadLine-Perl>=0:${PORTSDIR}/devel/p5-ReadLine-Perl
+RUN_DEPENDS= p5-ReadLine-Perl>=0:${PORTSDIR}/devel/p5-ReadLine-Perl
PERL_CONFIGURE= yes
@@ -22,13 +23,11 @@ MAN3= Term::ShellUI.3 \
Text::Shellwords::Cursor.3
post-install:
-
.if !defined(NOPORTEXAMPLES)
- @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
- @${MKDIR} ${EXAMPLESDIR}
-.for file in fileman-example synopsis synopsis-big tui-sample
- @${INSTALL_SCRIPT} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}
-.endfor
+ ${MKDIR} ${EXAMPLESDIR}/
+ ${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ cd ${WRKSRC}/examples/ && ${INSTALL_SCRIPT} \
+ fileman-example synopsis synopsis-big tui-sample ${EXAMPLESDIR}/
.endif
.include <bsd.port.mk>