aboutsummaryrefslogtreecommitdiffstats
path: root/shells/pash/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/pash/Makefile')
-rw-r--r--shells/pash/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/shells/pash/Makefile b/shells/pash/Makefile
new file mode 100644
index 000000000000..207964d6649d
--- /dev/null
+++ b/shells/pash/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: pash
+# Date created: 30 December 2000
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pash
+PORTVERSION= 2.2
+CATEGORIES= shells
+MASTER_SITES= http://www.chez-pierre.com/pash/Archives/
+DISTNAME= pash.sources
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+NO_WRKSUBDIR= yes
+
+MAKEFILE= makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pash ${PREFIX}/bin/pash
+
+post-install:
+ @${ECHO} "updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/osh /etc/shells.bak; \
+ ${ECHO} ${PREFIX}/bin/pash) > /etc/shells
+ @${RM} /etc/shells.bak
+
+.include <bsd.port.mk>