aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
Diffstat (limited to 'shells')
-rw-r--r--shells/scponly/Makefile4
-rw-r--r--shells/scponly/files/extra-patch-aa21
2 files changed, 25 insertions, 0 deletions
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
index 95b9acfe166c..619d8bcc0725 100644
--- a/shells/scponly/Makefile
+++ b/shells/scponly/Makefile
@@ -65,6 +65,10 @@ PLIST_SUB+= SCPONLY_CHROOT="@comment "
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 501105 && exists(/libexec/ld-elf.so.1)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-aa
+.endif
+
.if defined(WITHOUT_SCPONLY_WILDCARDS)
CONFIGURE_ARGS+=--disable-wildcards
.endif
diff --git a/shells/scponly/files/extra-patch-aa b/shells/scponly/files/extra-patch-aa
new file mode 100644
index 000000000000..4ecd72223afc
--- /dev/null
+++ b/shells/scponly/files/extra-patch-aa
@@ -0,0 +1,21 @@
+--- ./setup_chroot.sh.in.orig Fri Nov 21 00:14:36 2003
++++ ./setup_chroot.sh.in Fri Nov 21 00:15:13 2003
+@@ -106,6 +106,7 @@
+ @INSTALL@ -d $targetdir/usr/local/lib
+ @INSTALL@ -d $targetdir/usr/local/bin
+ @INSTALL@ -d $targetdir/lib
++@INSTALL@ -d $targetdir/libexec
+ @INSTALL@ -d $targetdir/usr/lib
+ @INSTALL@ -d $targetdir/usr/libexec
+ @INSTALL@ -d $targetdir/usr/libexec/openssh
+@@ -125,6 +126,10 @@
+ fi
+ if [ -f /lib/ld-linux.so.2 ]; then
+ LIB_LIST="$LIB_LIST /lib/ld-linux.so.2"
++ LDSOFOUND=1
++fi
++if [ -f /libexec/ld-elf.so.1 ]; then
++ LIB_LIST="$LIB_LIST /libexec/ld-elf.so.1"
+ LDSOFOUND=1
+ fi
+ if [ -f /usr/libexec/ld-elf.so.1 ]; then