aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
Diffstat (limited to 'shells')
-rw-r--r--shells/bash-completion/Makefile2
-rw-r--r--shells/bash-completion/files/patch-bash__completion11
2 files changed, 12 insertions, 1 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 8c866c8d7fb4..6cca80d7a307 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bash-completion
PORTVERSION= 2.1
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= shells
MASTER_SITES= http://bash-completion.alioth.debian.org/files/
diff --git a/shells/bash-completion/files/patch-bash__completion b/shells/bash-completion/files/patch-bash__completion
new file mode 100644
index 000000000000..6e6d95fa1a68
--- /dev/null
+++ b/shells/bash-completion/files/patch-bash__completion
@@ -0,0 +1,11 @@
+--- bash_completion.orig 2015-01-20 16:17:24 UTC
++++ bash_completion
+@@ -707,7 +707,7 @@ _init_completion()
+ fi
+ done
+
+- [[ $cword -eq 0 ]] && return 1
++ [[ $cword -le 0 ]] && return 1
+ prev=${words[cword-1]}
+
+ [[ ${split-} ]] && _split_longopt && split=true