aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/LPRng
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/LPRng')
-rw-r--r--sysutils/LPRng/Makefile8
-rw-r--r--sysutils/LPRng/files/patch-src-common-lpf.c23
2 files changed, 24 insertions, 7 deletions
diff --git a/sysutils/LPRng/Makefile b/sysutils/LPRng/Makefile
index 9195d847c578..c981c0dcbe70 100644
--- a/sysutils/LPRng/Makefile
+++ b/sysutils/LPRng/Makefile
@@ -48,12 +48,6 @@ MAN1= lpf.1 psbanner.1 lp.1 cancel.1 lprng_certs.1 lprng_index_certs.1 \
MAN5= printcap.5 lpd.conf.5 lpd.perms.5
MAN8= lpc.8 checkpc.8 lpd.8
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
pre-everything::
@${ECHO_MSG} "If you want to replace the default printing system with LPRng, use:"
@${ECHO_MSG} " make PREFIX=/usr SYSCONFDIR=/etc clean all install"
@@ -77,4 +71,4 @@ post-install:
.endif
@${SED} -e "s!DOCSDIR!${DOCSDIR}/!" ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/LPRng/files/patch-src-common-lpf.c b/sysutils/LPRng/files/patch-src-common-lpf.c
new file mode 100644
index 000000000000..8177fa57d687
--- /dev/null
+++ b/sysutils/LPRng/files/patch-src-common-lpf.c
@@ -0,0 +1,23 @@
+--- src/common/lpf.c.orig Wed Apr 16 03:37:42 2003
++++ src/common/lpf.c Thu Dec 18 18:58:29 2003
+@@ -188,7 +188,7 @@
+ int crlf; /* change lf to CRLF */
+
+ void getargs( int argc, char *argv[], char *envp[] );
+-void log( char *msg, ... );
++void lpf_log( char *msg, ... );
+ void logerr( char *msg, ... );
+ void logerr_die( char *msg, ... );
+ void fatal( char *msg, ... );
+@@ -312,9 +312,9 @@
+ }
+
+ #ifdef HAVE_STDARGS
+-void log(char *msg, ...)
++void lpf_log(char *msg, ...)
+ #else
+-void log( va_alist ) va_dcl
++void lpf_log( va_alist ) va_dcl
+ #endif
+ {
+ #ifndef HAVE_STDARGS