aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/bubblemon2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/bubblemon2/Makefile')
-rw-r--r--sysutils/bubblemon2/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/sysutils/bubblemon2/Makefile b/sysutils/bubblemon2/Makefile
index 7504f0b1ad25..187c62862eaa 100644
--- a/sysutils/bubblemon2/Makefile
+++ b/sysutils/bubblemon2/Makefile
@@ -5,39 +5,35 @@
# $FreeBSD$
PORTNAME= bubblemon2
-PORTVERSION= 2.0.1
-PORTREVISION= 3
+PORTVERSION= 2.0.3
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= bubblemon
DISTNAME= bubblemon-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Bubblemon2 is a system CPU and memory load monitor for GNOME2
+COMMENT= A system CPU and memory load monitor for GNOME2
LIB_DEPENDS= gtop-2.0:${PORTSDIR}/devel/libgtop2
USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnomepanel gnomeprefix gnometarget intlhack
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
-USE_GNOME= gnomehack gnomeprefix gnomepanel
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= bubblemon-gnome2.1
MANLANG= "" hu sv
-DOCS= AUTHORS COPYING ChangeLog FAQ PROFILING TRANSLATIONS NEWS README TODO
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ;' ${WRKSRC}/configure
+PORTDOCS= AUTHORS COPYING ChangeLog FAQ PROFILING TRANSLATIONS NEWS README TODO
post-install:
.if !defined(NOPORTDOCS)
- ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif