aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cfengine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/cfengine/Makefile')
-rw-r--r--sysutils/cfengine/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/sysutils/cfengine/Makefile b/sysutils/cfengine/Makefile
index 976e903599af..eed233e01ccd 100644
--- a/sysutils/cfengine/Makefile
+++ b/sysutils/cfengine/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= cfengine
-PORTVERSION= 1.6.1
+PORTVERSION= 1.6.2
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iu.hioslo.no/pub/cfengine/ \
${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= cfengine
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
@@ -18,19 +18,17 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= wrap.7:${PORTSDIR}/security/tcp_wrapper
.endif
-CFLAGS+= -pthread
-USE_AUTOCONF=yes
-USE_GMAKE=yes
-MAKE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
+USE_GMAKE= yes
+USE_AUTOMAKE= yes
MAN8= cfengine.8
+pre-configure:
+ @cd ${WRKSRC} && aclocal && autoheader
+
post-install:
-.for binary in cfengine cfd cfrun cfkey
- strip ${PREFIX}/sbin/${binary}
-.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
.for docfile in cf-security.html cfengine-Reference.html cfengine-Tutorial.html
${INSTALL_MAN} ${WRKSRC}/doc/${docfile} ${PREFIX}/share/doc/${PORTNAME}
.endfor