aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cpuburn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/cpuburn/Makefile')
-rw-r--r--sysutils/cpuburn/Makefile43
1 files changed, 0 insertions, 43 deletions
diff --git a/sysutils/cpuburn/Makefile b/sysutils/cpuburn/Makefile
deleted file mode 100644
index d51afb00794f..000000000000
--- a/sysutils/cpuburn/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# New ports collection makefile for: cpuburn
-# Date created: Apr 1, 2001
-# Whom: Mark Pulford <mark@kyne.com.au>
-#
-# $FreeBSD$
-#
-
-PORTNAME= cpuburn
-PORTVERSION= 1.4
-CATEGORIES= sysutils
-MASTER_SITES= http://pages.sbcglobal.net/redelm/
-DISTNAME= cpuburn_${PORTVERSION:S/./_/g}
-EXTRACT_SUFX= _tar.gz
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= CPU/memory stress testing utilities
-
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-11-01
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-ONLY_FOR_ARCHS= i386 amd64
-
-PORTDOCS= README Design
-CPUS= BX K6 K7 MMX P5 P6
-PLIST_FILES= ${CPUS:C+^+bin/burn+g}
-
-do-build:
-.for CPU in ${CPUS}
- ${CC} -m32 -s -nostdlib -o ${WRKSRC}/burn${CPU} ${WRKSRC}/burn${CPU}.S
-.endfor
-
-do-install:
-.for CPU in ${CPUS}
- ${INSTALL_PROGRAM} ${WRKSRC}/burn${CPU} ${PREFIX}/bin
-.endfor
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Design ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>