aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/dar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/dar/Makefile')
-rw-r--r--sysutils/dar/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/sysutils/dar/Makefile b/sysutils/dar/Makefile
index f54a68aa31bb..954fa8fe8778 100644
--- a/sysutils/dar/Makefile
+++ b/sysutils/dar/Makefile
@@ -6,16 +6,28 @@
#
PORTNAME= dar
-PORTVERSION= 2.1.5
+PORTVERSION= 2.2.0
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}
MAINTAINER= ebrandi@fugspbr.org
-COMMENT= DAR is a full featured command-line backup tool, aimed for disks
+COMMENT= A full featured command-line backup tool, aimed for disks
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
MAN1= dar.1 dar_cp.1 dar_manager.1 dar_slave.1 dar_xform.1
.include <bsd.port.mk>