aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/dfc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/dfc/Makefile')
-rw-r--r--sysutils/dfc/Makefile23
1 files changed, 16 insertions, 7 deletions
diff --git a/sysutils/dfc/Makefile b/sysutils/dfc/Makefile
index 2508f47300f8..ca0732841d6a 100644
--- a/sysutils/dfc/Makefile
+++ b/sysutils/dfc/Makefile
@@ -6,22 +6,31 @@
#
PORTNAME= dfc
-PORTVERSION= 2.5.0
+PORTVERSION= 3.0.0
CATEGORIES= sysutils
-MASTER_SITES= http://projects.gw-computing.net/attachments/download/42/
+MASTER_SITES= http://projects.gw-computing.net/attachments/download/63/
MAINTAINER= bapt@FreeBSD.org
COMMENT= Display file system space usage using graph and colors
LICENSE= BSD
-PLIST_FILES= bin/dfc
+OPTIONS_DEFINE= NLS
+
+USE_CMAKE= yes
+CMAKE_ARGS+= -DMAN_PATH=${MANPREFIX}/man -DDFC_DOC_PATH=${DOCSDIR}
+MANLANG= "" fr
MAN1= dfc.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${OSVERSION} < 800000
-BROKEN= does not compile on FreeBSD 7.X
+.if ${PORT_OPTIONS:MNLS}
+CMAKE_ARGS+= -DNLS_ENABLED=true
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CMAKE_ARGS+= -DNLS_ENABLED=false
+PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>