aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/dump9660/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/dump9660/Makefile')
-rw-r--r--sysutils/dump9660/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/sysutils/dump9660/Makefile b/sysutils/dump9660/Makefile
index b863a35531b6..69eaef03ab92 100644
--- a/sysutils/dump9660/Makefile
+++ b/sysutils/dump9660/Makefile
@@ -19,7 +19,7 @@ MAN8= mk9660.8
MAN5= proto.5
MLINKS= mk9660.8 dump9660.8
-ONLY_FOR_ARCHS= alpha i386 powerpc
+ONLY_FOR_ARCHS= i386 powerpc
OBJTYPE= ${MACHINE_ARCH:S/i386/386/:S/powerpc/power/}
MAKE_ENV= systype=${OPSYS} objtype=${OBJTYPE}
@@ -32,4 +32,10 @@ post-patch:
cd ${WRKSRC}/libunix; \
for f in *.s; do ${MV} $$f $${f%.s}.S; done
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc
+.endif
+
+.include <bsd.port.post.mk>