aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/fcron/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/fcron/Makefile')
-rw-r--r--sysutils/fcron/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/sysutils/fcron/Makefile b/sysutils/fcron/Makefile
index bf3171be3568..d7c3beea5a02 100644
--- a/sysutils/fcron/Makefile
+++ b/sysutils/fcron/Makefile
@@ -8,7 +8,7 @@
PORTNAME= fcron
PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://fcron.free.fr/
@@ -23,7 +23,7 @@ CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --with-cflags="${CFLAGS}" \
--with-answer-all=yes
.if !defined(NOPORTDOCS)
-CONFIGURE_ARGS+= --with-docdir=${PREFIX}/share/doc/fcron
+CONFIGURE_ARGS+= --with-docdir=${DOCSDIR}
PLIST_SUB= PORTVERSION=${PORTVERSION}
.endif
@@ -35,7 +35,10 @@ MAN5= fcrontab.5 fcron.conf.5
MAN8= fcron.8
post-install:
- @${CP} ${WRKSRC}/files/fcron.allow ${PREFIX}/etc/fcron.allow.dist
- @${CP} ${WRKSRC}/files/fcron.deny ${PREFIX}/etc/fcron.deny.dist
+.for i in allow deny conf
+.if !exists(${PREFIX}/etc/fcron.$i)
+ @${CP} -p ${PREFIX}/etc/fcron.$i.dist ${PREFIX}/etc/fcron.$i
+.endif
+.endfor
.include <bsd.port.mk>