aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/file/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/file/Makefile')
-rw-r--r--sysutils/file/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/sysutils/file/Makefile b/sysutils/file/Makefile
index ff34c7c52824..a1edc3de57aa 100644
--- a/sysutils/file/Makefile
+++ b/sysutils/file/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: file
-# Date created: 2001-11-10
-# Whom: Jason Harris <jharris@widomaker.com>
-#
+# Created by: Jason Harris <jharris@widomaker.com>
# $FreeBSD$
-#
PORTNAME= file
-PORTVERSION= 5.11
+PORTVERSION= 5.12
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.astron.com/pub/file/ \
ftp://ftp.fu-berlin.de/unix/tools/file/
@@ -14,6 +10,8 @@ MASTER_SITES= ftp://ftp.astron.com/pub/file/ \
MAINTAINER= bf@FreeBSD.org
COMMENT= Utility to determine file type
+LICENSE= BSD
+
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
@@ -25,10 +23,17 @@ MAN1= file.1
MAN3= libmagic.3
MAN5= magic.5
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800000
+CONFIGURE_ENV+= gl_cv_cc_visibility=no
+.endif
+
check regression-test test: build
@( cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} check ; )
post-patch:
@${REINPLACE_CMD} -e 's|$(datadir)/misc|$(datadir)/${PORTNAME}|g' \
${WRKSRC}/configure
-.include <bsd.port.mk>
+
+.include <bsd.port.post.mk>