aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/fusefs-ifuse
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/fusefs-ifuse')
-rw-r--r--sysutils/fusefs-ifuse/Makefile43
-rw-r--r--sysutils/fusefs-ifuse/distinfo2
-rw-r--r--sysutils/fusefs-ifuse/files/pkg-message.in6
-rw-r--r--sysutils/fusefs-ifuse/pkg-descr6
4 files changed, 57 insertions, 0 deletions
diff --git a/sysutils/fusefs-ifuse/Makefile b/sysutils/fusefs-ifuse/Makefile
new file mode 100644
index 000000000000..f1694e71d9bb
--- /dev/null
+++ b/sysutils/fusefs-ifuse/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: fusefs-ifuse
+# Date created: 09 October 2011
+# Whom: Gabor Zahemszky
+#
+# $FreeBSD$
+#
+
+PORTNAME= ifuse
+PORTVERSION= 1.1.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.libimobiledevice.org/downloads/
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= Gabor@Zahemszky.HU
+COMMENT= Mount iPod Touch / iPhone directories over USB
+
+# LICENSE= LGPL21
+# LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= fusefs-libs>2.4.1:${PORTSDIR}/sysutils/fusefs-libs
+
+LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs \
+ imobiledevice.1:${PORTSDIR}/comms/libimobiledevice
+
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod \
+ usbmuxd:${PORTSDIR}/comms/usbmuxd
+
+SUB_FILES= pkg-message
+USE_BZIP2= yes
+USE_GNOME= glib20 pkgconfig
+
+GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_JOBS_SAFE= yes
+CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= ${PTHREAD_CFLAGS}
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-ifuse/distinfo b/sysutils/fusefs-ifuse/distinfo
new file mode 100644
index 000000000000..f84684e099ec
--- /dev/null
+++ b/sysutils/fusefs-ifuse/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ifuse-1.1.1.tar.bz2) = 86ea0753ad42af1f5575b0e3b510b51c7ff55dd54b43bf328efb6c417e564d36
+SIZE (ifuse-1.1.1.tar.bz2) = 82736
diff --git a/sysutils/fusefs-ifuse/files/pkg-message.in b/sysutils/fusefs-ifuse/files/pkg-message.in
new file mode 100644
index 000000000000..73148e3da1f8
--- /dev/null
+++ b/sysutils/fusefs-ifuse/files/pkg-message.in
@@ -0,0 +1,6 @@
+You should run usbmuxd, and after plugging in your iGadget, run
+
+ ifuse -o allow_other /mnt/ipod
+
+- after it, you can reach it's files, and
+use eg. gtkpod to add/delete musics/pictures to it.
diff --git a/sysutils/fusefs-ifuse/pkg-descr b/sysutils/fusefs-ifuse/pkg-descr
new file mode 100644
index 000000000000..d6b4d9b5ff5e
--- /dev/null
+++ b/sysutils/fusefs-ifuse/pkg-descr
@@ -0,0 +1,6 @@
+iFuse is a tool to reach iPod Touch and iPhone filesystems over USB
+(w/out the need of JailBreaking, and installing SSH-server on your iGadget).
+iFuse is useful if you want to mount the device manually or
+if you do not have GNOME with GVFS or KDE with kio-ufc installed
+
+WWW: http://www.libimobiledevice.org