aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gnome-system-tools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gnome-system-tools/Makefile')
-rw-r--r--sysutils/gnome-system-tools/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/sysutils/gnome-system-tools/Makefile b/sysutils/gnome-system-tools/Makefile
index 6d3799d618fc..127fd1c3f2c8 100644
--- a/sysutils/gnome-system-tools/Makefile
+++ b/sysutils/gnome-system-tools/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gnomesystemtools
-PORTVERSION= 0.90.0
-PORTREVISION= 1
+PORTVERSION= 0.91.0
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-system-tools/0.90
+MASTER_SITE_SUBDIR= sources/gnome-system-tools/0.91
DISTNAME= gnome-system-tools-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
@@ -25,4 +24,13 @@ USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+CONFIGURE_ARGS+= --enable-services
+PLIST_SUB+= SERVICES=""
+.else
+PLIST_SUB+= SERVICES="@comment "
+.endif
+
+.include <bsd.port.post.mk>