aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gnomefind/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gnomefind/Makefile')
-rw-r--r--sysutils/gnomefind/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/gnomefind/Makefile b/sysutils/gnomefind/Makefile
new file mode 100644
index 000000000000..6cd712730409
--- /dev/null
+++ b/sysutils/gnomefind/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gnomefind
+# Date created: 26 May 2000
+# Whom: Maxim Sobolev
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomefind
+PORTVERSION= 0.4
+CATEGORIES= sysutils gnome
+MASTER_SITES= http://download.sourceforge.net/gnome-find/
+DISTNAME= gnome-find-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ glade.3:${PORTSDIR}/devel/libglade
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-lgnuregex -L${LOCALBASE}/lib"
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+MAN1= gnome-find.1
+
+.include <bsd.port.mk>