aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/healthd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/healthd/Makefile')
-rw-r--r--sysutils/healthd/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/sysutils/healthd/Makefile b/sysutils/healthd/Makefile
index 0a3f46c5eb7a..46d727c31bd1 100644
--- a/sysutils/healthd/Makefile
+++ b/sysutils/healthd/Makefile
@@ -1,18 +1,28 @@
# New ports collection makefile for: healthd
-# Version required: 0.1
-# Date created: 24 October 1999
+# Version required: 0.2
+# Date created: 15 November 1999
# Whom: jim@thehousleys.net
#
# $FreeBSD$
#
-DISTNAME= healthd-0.1
+DISTNAME= healthd-0.2
CATEGORIES= sysutils
-MASTER_SITES= http://www.thehousleys.net/healthd/
+MASTER_SITES= http://healthd.thehousleys.net/
MAINTAINER= jim@thehousleys.net
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --exec-prefix=${PREFIX}
+MAN8= healthd.8
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/rc.d/healthd.sh ]; then \
+ ${ECHO} "Installing ${PREFIX}/etc/rc.d/healthd.sh startup file."; \
+ ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/healthd.sh; \
+ ${ECHO} "[ -x ${PREFIX}/bin/healthd ] && ${PREFIX}/bin/healthd > /dev/null && ${ECHO} -n ' healthd'" >> ${PREFIX}/etc/rc.d/healthd.sh; \
+ ${CHMOD} 751 ${PREFIX}/etc/rc.d/healthd.sh; \
+ fi
+
.include <bsd.port.mk>