aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/httplog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/httplog/Makefile')
-rw-r--r--sysutils/httplog/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/sysutils/httplog/Makefile b/sysutils/httplog/Makefile
index e2c52e9c8a34..37a806316928 100644
--- a/sysutils/httplog/Makefile
+++ b/sysutils/httplog/Makefile
@@ -10,18 +10,24 @@ MASTER_SITES= ftp://ftp.nuug.no/pub/anders/distfiles/
MAINTAINER= ports@FreeBSD.org
COMMENT= Apache log rollover program with strftime(3) filename support
+LICENSE= FSL
+LICENSE_NAME= Free software license
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
+
PORTDOCS= ChangeLog README
OPTIONS_DEFINE= DOCS
post-patch:
- (cd ${WRKSRC} && \
- ${REINPLACE_CMD} -e "s@<wait.h>@<sys/wait.h>@" httplog.c && \
- ${REINPLACE_CMD} -e \
+ @${REINPLACE_CMD} -e "s@<wait.h>@<sys/wait.h>@" \
+ ${WRKSRC}/httplog.c
+ @${REINPLACE_CMD} -e \
"s@/var/lib/apache/bin/httplog@${PREFIX}/sbin/httplog@" \
- httplog.8)
+ ${WRKSRC}/httplog.8
do-build:
(cd ${WRKSRC} && ${CC} ${CFLAGS} -o httplog httplog.c -lz)
@@ -29,7 +35,9 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/httplog ${STAGEDIR}${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/httplog.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor