aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/knutclient/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/knutclient/Makefile')
-rw-r--r--sysutils/knutclient/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/sysutils/knutclient/Makefile b/sysutils/knutclient/Makefile
new file mode 100644
index 000000000000..7da8001bc3a8
--- /dev/null
+++ b/sysutils/knutclient/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: KDE Nut Client
+# Date created: Mon Apr 28 05:30:59 UTC 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= knutclient
+PORTVERSION= 0.6.0
+CATEGORIES= sysutils kde
+MASTER_SITES= ftp://ftp.buzuluk.cz/pub/alo/knutclient/
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A visual client for UPS system NUT
+
+USE_KDELIBS_VER=3
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-mt
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|-O2||' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
ish?id=c42f68916ebd3e322291f5988b94c473b5d87762'>Tie some forgotten ports into the build.marcus2003-08-311-1/+3 * correct the path of MASTERDIRleeym2003-08-261-1/+1 * Bad MASTERDIR valueedwin2003-08-222-2/+2 * Add a COMMENT filearved2003-08-191-0/+1 * - Update the Categories after Repocopy.arved2003-08-1912-19/+19 * Add an implicit pl- PKGNAMEPREFIX for all Polish ports.marcus2003-08-171-0/+4 * Add empty subdir makefiles for the new dns and polish categories. Thesekris2003-08-161-0/+4 * Fix the REINPLACE_CMDarved2003-08-092-2/+2 * Move configurationfile from /etc to ${PREFIX}/etc.arved2003-08-042-0/+18 * Update KDE to the latest official release, KDE 3.1.3lofi2003-07-296-4/+12 * Add portname to the title of the dialogboxarved2003-07-222-2/+2 * Add ekg, a client for the polish IM System gadu-gaduarved2003-07-215-0/+100 * merge from kde-freebsd Repository:arved2003-06-164-0/+24 * Update to KDE 3.1.2lioux2003-05-204-8/+8 * New port: localized messages and documentation for kofficelioux2003-05-2012-0/+210 * - update to 1.9.1ipetef2003-05-114-6/+6 * - update to 1.0.0petef2003-05-1110-88/+256 * Remove USE_GNOMENG.marcus2003-04-212-2/+0 * Rejoice, for the long awaited upgrade to kde 3.1.1 is here!alane2003-04-064-2/+4 * misc/pl-sms: update to a new version 1.9.1hedwin2003-03-308-56/+52 * Clear moonlight beckons.ade2003-03-074-2/+2 * Remove pkg-comment from remaining master/slave port sets.ade2003-03-072-1/+1 * De-pkg-comment.knu2003-02-214-2/+2 * De-pkg-comment.knu2003-02-214-2/+2 * De-pkg-comment.knu2003-02-212-1/+1 * Upgrade kde-i18n to 3.1. Note that the following modules did not get awill2003-01-294-56/+230 * chase gdbm lib versionijliao2003-01-032-2/+2 * Fix unassociated shell command.nork2002-12-112-2/+4 * Fix unassociated shell command.nork2002-12-112-2/+0 * - upgrade to version 0.2.2sada2002-11-1110-60/+56 * o Rollback PORTCOMMENT modifications while this feature's implementationlioux2002-11-112-2/+1 * Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-072-1/+2 * 1. Removed comments from pkg-plist files per will's request.alane2002-10-112-2/+2 * build aspell with dictionarydinoex2002-09-103-0/+23 * Deploy USE_GNOMENG infrastructurelioux2002-09-032-8/+12 * Update to 3.0.3. Not much changed here: [1] i18n PKGNAMEs converted towill2002-08-254-8/+6 * Add OpenOffice.org spelling dictionary ports. They are based on MySpell,mbr2002-08-124-2/+19 * 1. Changed the lib depends on gettext to a build depends. This will meanalane2002-08-032-4/+4 * Bump PORTREVISION. KDE is fragile enough in its dependencies; we don'talane2002-08-022-0/+2 * Chase shlib rev of devel/gettextade2002-08-022-2/+2 * Add support for spelling dictionaries. Remove the pkg-plist for thembr2002-07-162-0/+2 * Fix MASTER_SITE_SUBDIR.will2002-07-102-2/+2 * Update to 3.0.2 -- full log available in ports/x11/kde3/Makefile,v 1.51.will2002-07-056-146/+40 * Upgrade to KDE 3.0.1. The delay in this upgrade is mainly due to thewill2002-06-166-4/+250 * Add Polish OpenOffice slave portmbr2002-06-152-0/+30 * Please welcome Qt3/KDE3 to our ports tree. This includes work since thewill2002-04-22