aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/lxtask
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/lxtask')
-rw-r--r--sysutils/lxtask/Makefile35
-rw-r--r--sysutils/lxtask/pkg-descr4
-rw-r--r--sysutils/lxtask/pkg-message18
3 files changed, 43 insertions, 14 deletions
diff --git a/sysutils/lxtask/Makefile b/sysutils/lxtask/Makefile
index 6c2a9309776c..9600b3cdbacf 100644
--- a/sysutils/lxtask/Makefile
+++ b/sysutils/lxtask/Makefile
@@ -5,30 +5,47 @@ PORTNAME= lxtask
PORTVERSION= 0.1.4
PORTREVISION= 1
CATEGORIES= sysutils gnome
-MASTER_SITES= SF/lxde/LXTask%20%28task%20manager%29/LXTask%20${PORTVERSION}
+MASTER_SITES= SF/lxde/LXTask%20%28task%20manager%29/LXTask%20${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Lightweight desktop-independent task manager
-USE_GNOME= gtk20 intlhack
-USE_GMAKE= yes
+LICENSE= GPLv2
+
USES= iconv
+USE_GNOME= gtk20 intlhack
GNU_CONFIGURE= yes
+USE_GMAKE= yes
USE_LDCONFIG= yes
+PORTDOCS= AUTHORS README TODO
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e 's|po src|src|' \
+ ${WRKSRC}/Makefile.in
.endif
post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+ @${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
.include <bsd.port.mk>
diff --git a/sysutils/lxtask/pkg-descr b/sysutils/lxtask/pkg-descr
index 551e5d6d30ea..f30509f82089 100644
--- a/sysutils/lxtask/pkg-descr
+++ b/sysutils/lxtask/pkg-descr
@@ -1,3 +1,5 @@
-lxtask is a lightweight desktop-independent task manager.
+LXTask - lightweight and desktop-independent task manager derived from
+xfce4-taskmanager with all dependencies on xfce removed, new features,
+and some improvement of the user interface.
WWW: http://lxde.sourceforge.net/
diff --git a/sysutils/lxtask/pkg-message b/sysutils/lxtask/pkg-message
index e8f04187b5e7..8be9eb26e2f0 100644
--- a/sysutils/lxtask/pkg-message
+++ b/sysutils/lxtask/pkg-message
@@ -1,4 +1,14 @@
-******************************************************
-This ports works only if linprocfs is mounted. Ensure
-that linprocfs is mounted before running.
-*****************************************************
+################################################################################
+
+This program will attempt to obtain some system information by accessing files
+in linprocfs. You must mount linprocfs filesystem for this to work correctly.
+This can be accomplished by adding the following line to your /etc/fstab file:
+
+# Device Mountpoint FStype Options Dump Pass
+linprocfs /compat/linux/proc linprocfs rw 0 0
+
+and then, as root, executing the command:
+
+mount linprocfs
+
+################################################################################