aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/munin-common
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/munin-common')
-rw-r--r--sysutils/munin-common/Makefile46
-rw-r--r--sysutils/munin-common/distinfo3
-rw-r--r--sysutils/munin-common/files/patch-Makefile11
-rw-r--r--sysutils/munin-common/files/patch-Makefile.config96
-rw-r--r--sysutils/munin-common/files/pkg-message.in8
-rw-r--r--sysutils/munin-common/pkg-descr14
-rw-r--r--sysutils/munin-common/pkg-plist8
7 files changed, 186 insertions, 0 deletions
diff --git a/sysutils/munin-common/Makefile b/sysutils/munin-common/Makefile
new file mode 100644
index 000000000000..f4d352923f00
--- /dev/null
+++ b/sysutils/munin-common/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: munin-common
+# Date created: 10 February 2010
+# Whom: Sean Rees <sean@rees.us>
+#
+# $FreeBSD$
+#
+
+PORTNAME= munin
+PORTVERSION= 1.4.3
+CATEGORIES= sysutils perl5
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION}
+PKGNAMESUFFIX= -common
+
+MAINTAINER= des@FreeBSD.org
+COMMENT= Common components between a munin node and server
+
+BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
+ ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+
+USE_PERL5= yes
+USE_GMAKE= yes
+PATCH_STRIP= -p1
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+MAKE_ARGS= LIBDIR=${DATADIR} CONFDIR=${ETCDIR} \
+ PERL=${PERL} SITE_PERL_REL=${SITE_PERL_REL}
+ALL_TARGET= build-common-prime
+INSTALL_TARGET= install-common
+
+MAN3= Munin::Common::Config.3 \
+ Munin::Common::Defaults.3 \
+ Munin::Common::TLS.3 \
+ Munin::Common::TLSClient.3 \
+ Munin::Common::TLSServer.3 \
+ Munin::Common::Timeout.3
+
+SUB_FILES= pkg-message
+
+post-install:
+ @(cd ${WRKSRC}/common/blib/libdoc && for man in ${MAN3} ; do \
+ ${INSTALL_MAN} -C $$man ${PREFIX}/man/man3; \
+ done)
+
+.include <bsd.port.mk>
diff --git a/sysutils/munin-common/distinfo b/sysutils/munin-common/distinfo
new file mode 100644
index 000000000000..b74600488bbb
--- /dev/null
+++ b/sysutils/munin-common/distinfo
@@ -0,0 +1,3 @@
+MD5 (munin-1.4.3.tar.gz) = 229646facc4e2bca6511b20b3e5eb73f
+SHA256 (munin-1.4.3.tar.gz) = c5f1c8e5e71e9ffd5c74037ec3eec4da362fd2aecea3c788abb7d92b461834d0
+SIZE (munin-1.4.3.tar.gz) = 1205698
diff --git a/sysutils/munin-common/files/patch-Makefile b/sysutils/munin-common/files/patch-Makefile
new file mode 100644
index 000000000000..22cd60e4fefe
--- /dev/null
+++ b/sysutils/munin-common/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2010-01-30 10:49:44.000000000 -0700
++++ Makefile 2010-01-30 10:49:53.000000000 -0700
+@@ -69,7 +69,7 @@
+ mkdir -p $(LOGDIR)
+ mkdir -p $(STATEDIR)
+ mkdir -p $(CONFDIR)
+- $(CHOWN) $(USER) $(LOGDIR) $(STATEDIR)
++ $(CHOWN) $(USER) $(STATEDIR)
+
+ install-master-prime: $(INFILES_MASTER) install-pre install-master
+ mkdir -p $(CONFDIR)/templates
diff --git a/sysutils/munin-common/files/patch-Makefile.config b/sysutils/munin-common/files/patch-Makefile.config
new file mode 100644
index 000000000000..7b9627fb5304
--- /dev/null
+++ b/sysutils/munin-common/files/patch-Makefile.config
@@ -0,0 +1,96 @@
+--- Makefile.config.orig 2009-12-30 05:55:56.000000000 -0700
++++ Makefile.config 2010-01-30 11:17:34.000000000 -0700
+@@ -17,29 +17,33 @@
+ #
+ # the base of the Munin installation.
+ #
+-PREFIX = $(DESTDIR)/opt/munin
++ifdef PREFIX
++UPREFIX=$(PREFIX)
++else
++UPREFIX=/usr
++endif
+
+ # Where Munin keeps its configurations (server.conf, client.conf, ++)
+-CONFDIR = $(DESTDIR)/etc/opt/munin
++CONFDIR = $(PREFIX)/etc/munin
+
+ # Server only - where to put munin-cron
+-BINDIR = $(PREFIX)/bin
++BINDIR = $(UPREFIX)/bin
+
+ # Client only - where to put munin-node, munin-node-configure, and munin-run
+-SBINDIR = $(PREFIX)/sbin
++SBINDIR = $(UPREFIX)/sbin
+
+ # Where to put text and html documentation
+-DOCDIR = $(PREFIX)/doc
++DOCDIR = $(UPREFIX)/doc
+
+ # Where to put man pages
+-MANDIR = $(PREFIX)/man
++MANDIR = $(UPREFIX)/man
+
+ # Where to put internal binaries and plugin repository
+-LIBDIR = $(PREFIX)/lib
++LIBDIR = $(DATADIR)
+
+ # Server only - Output directory
+-HTMLDIR = $(PREFIX)/www/docs
+-CGIDIR = $(PREFIX)/www/cgi
++HTMLDIR = $(WWWDIR)
++CGIDIR = $(PREFIX)/www/cgi-bin
+
+ # Server only - spool directory for data gathered from nodes by
+ # munin-gather - experimental. Place on ramdisk to make munin
+@@ -52,21 +56,20 @@
+ # SSPOOLDIR := /tmp/muninspool
+
+ # Client only - Where to put RRD files and other intenal data
+-DBDIR = $(DESTDIR)/var/opt/munin
++DBDIR = $(PREFIX)/var/munin
+
+ # Client only - Where plugins should put their states. Must be writable by
+ # group "munin", and should be preserved between reboots
+ PLUGSTATE = $(DBDIR)/plugin-state
+
+ # Where Munin should place its logs.
+-LOGDIR = $(PREFIX)/log/munin
++LOGDIR = /var/log/munin-main
+
+ # Location of PID files and other statefiles. On the server, must be
+ # writable by the user "munin".
+-STATEDIR = $(DESTDIR)/var/run/munin
++STATEDIR = /var/run/munin
+
+ # The perl interpreter to use
+-PERL := $(shell which perl)
+
+ # The python interpreter to use (used by some plugins)
+ PYTHON := /usr/bin/env python
+@@ -95,11 +98,11 @@
+ GOODSH := $(shell PATH=`getconf PATH` sh -c 'type sh | sed "s/.* //"')
+
+ # Path of bash for bash specific plugins
+-BASH := /bin/bash
++BASH := /usr/local/bin/bash
+
+ # Server only - Where to install the perl libraries
+ PERLSITELIB := $(shell $(PERL) -V:sitelib | cut -d"'" -f2)
+-PERLLIB = $(DESTDIR)$(PERLSITELIB)
++PERLLIB = $(PREFIX)/$(SITE_PERL_REL)
+
+ # Client only - Install plugins for this architecture
+ OSTYPE := $(shell uname | tr '[A-Z]' '[a-z]')
+@@ -126,9 +129,8 @@
+ # Which command to use to check if the USER and GROUP to run Munin as, exists.
+ # These will work on most modern OSes:
+ #
+-GETENT := $(shell which getent || which true 2>/dev/null)
+-CHECKUSER := $(shell $(GETENT) passwd $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
+-CHECKGROUP := $(shell $(GETENT) group $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
++CHECKUSER:= $(shell /usr/sbin/pw user show $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
++CHECKGROUP:= $(shell /usr/sbin/pw group show $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
+
+ # For OSX, comment out the previous two lines and comment in these
+ #
diff --git a/sysutils/munin-common/files/pkg-message.in b/sysutils/munin-common/files/pkg-message.in
new file mode 100644
index 000000000000..df049437efa1
--- /dev/null
+++ b/sysutils/munin-common/files/pkg-message.in
@@ -0,0 +1,8 @@
+********************************************************************
+Unless this file already existed, a sample configuration file
+has been placed in %%PREFIX%%/etc/munin/munin.conf.
+
+Please edit it according to your needs.
+
+The Munin server will be run from cron under the user 'munin'.
+********************************************************************
diff --git a/sysutils/munin-common/pkg-descr b/sysutils/munin-common/pkg-descr
new file mode 100644
index 000000000000..666948252297
--- /dev/null
+++ b/sysutils/munin-common/pkg-descr
@@ -0,0 +1,14 @@
+Munin network-wide graphing framework (node)
+
+Munin is a tool for graphing all sorts of information about one or more
+servers and displaying it in a web interface. It uses the excellent
+RRDTool (written by Tobi Oetiker) and is written in Perl. Munin has a
+master/node architecture. The master connects to all the nodes at regular
+intervals, and asks them for data. It then stores the data in RRD-files,
+and (if needed) updates the graphs. One of the main goals have been ease
+of creating own "plugins" (graphs).
+
+This are the common components to drive both the server and the node components
+of munin.
+
+WWW: http://www.linpro.no/projects/munin/
diff --git a/sysutils/munin-common/pkg-plist b/sysutils/munin-common/pkg-plist
new file mode 100644
index 000000000000..ff50d7e8415b
--- /dev/null
+++ b/sysutils/munin-common/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Munin/Common/Config.pm
+%%SITE_PERL%%/Munin/Common/Defaults.pm
+%%SITE_PERL%%/Munin/Common/TLS.pm
+%%SITE_PERL%%/Munin/Common/TLSClient.pm
+%%SITE_PERL%%/Munin/Common/TLSServer.pm
+%%SITE_PERL%%/Munin/Common/Timeout.pm
+@dirrm %%SITE_PERL%%/Munin/Common
+@dirrm %%SITE_PERL%%/Munin