aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/munin-master
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/munin-master')
-rw-r--r--sysutils/munin-master/Makefile2
-rw-r--r--sysutils/munin-master/files/pkg-message.in4
-rw-r--r--sysutils/munin-master/pkg-deinstall38
-rw-r--r--sysutils/munin-master/pkg-install47
4 files changed, 53 insertions, 38 deletions
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index 057da73ed52a..6bacc0774581 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -47,8 +47,6 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include "${.CURDIR}/../munin-common/munin.mk"
-EXTRA_PATCHES= ${MUNIN_PATCHES}
-DISTINFO_FILE= ${MUNIN_DISTINFO}
ALL_TARGET= infiles build-master build-man
INSTALL_TARGET= install-master-prime
NO_ARCH= yes
diff --git a/sysutils/munin-master/files/pkg-message.in b/sysutils/munin-master/files/pkg-message.in
index d32f17e6286d..0706e6e70962 100644
--- a/sysutils/munin-master/files/pkg-message.in
+++ b/sysutils/munin-master/files/pkg-message.in
@@ -5,4 +5,8 @@ has been placed in %%ETCDIR%%/munin.conf.
Please edit it according to your needs.
The Munin server will be run from cron under the user 'munin'.
+
+If you need to customize the munin crontab, remove the lines
+containing #BEGIN_MUNIN_MAIN and #END_MUNIN_MAIN, and add a line
+with #MANUAL_MUNIN_CRONTAB.
********************************************************************
diff --git a/sysutils/munin-master/pkg-deinstall b/sysutils/munin-master/pkg-deinstall
index ae415c932f23..d0898da7540e 100644
--- a/sysutils/munin-master/pkg-deinstall
+++ b/sysutils/munin-master/pkg-deinstall
@@ -1,14 +1,17 @@
#! /bin/sh
+# ex:sw=4 sts=4
ask() {
local question default answer
question=$1
default=$2
- if [ -z "${PACKAGE_BUILDING}" -a -z "${BATCH}" ]; then
+ if [ -z "${PACKAGE_BUILDING}" -a -z "${BATCH}" ]
+ then
read -p "${question} [${default}]? " answer
fi
- if [ x${answer} = x ]; then
+ if [ x${answer} = x ]
+ then
answer=${default}
fi
echo ${answer}
@@ -36,7 +39,8 @@ delete_crontab_entries() {
TMPFILE=`mktemp -t munin` || exit 1
crontab -u munin -l | sed -e "/^$b\$/,/^$e\$/d" -e '/^[ ]*#/d' -e '/^$/d' > $TMPFILE
- if [ -s $TMPFILE ]; then
+ if [ -s $TMPFILE ]
+ then
crontab -u munin -l | sed -e "/^$b\$/,/^$e\$/d" | crontab -u munin -
echo "The crontab for user munin had manually created entries."
echo "Only the automatically created entries have been removed."
@@ -50,8 +54,8 @@ delete_crontab_entries() {
}
delnewsyslog() {
- tmp="/etc/#munin-node$$"
- sed -e '/^\/var\/log\/munin\/\*\.log[ ]/d' /etc/newsyslog.conf >${tmp}
+ tmp=`mktemp -t munin` || exit 1
+ sed -e '/^\/var\/log\/munin\/\*\.log[ ]/d' /etc/newsyslog.conf >${tmp}
cat ${tmp} > /etc/newsyslog.conf
rm ${tmp}
}
@@ -59,23 +63,27 @@ delnewsyslog() {
newsyslog() {
ENTRY=`fgrep '/var/log/munin/*' /etc/newsyslog.conf`
DEFAULT='/var/log/munin/*.log munin:munin 644 7 * @T00 GNWZ'
- if [ -z "$ENTRY" ]; then
- exit 0
- elif [ "$ENTRY" = "$DEFAULT" ]; then
- delnewsyslog
+ if [ -z "$ENTRY" ]
+ then
+ exit 0
+ elif [ "$ENTRY" = "$DEFAULT" ]
+ then
+ delnewsyslog
elif yesno "You have changed the default munin-master entry in \"/etc/newsyslog.conf\".
-Do you want me to delete it?" y; then
- delnewsyslog
- echo "Done."
+Do you want me to delete it?" y
+ then
+ delnewsyslog
+ echo "Done."
fi
}
case $2 in
DEINSTALL)
- if [ -z "${PACKAGE_BUILDING}" ]; then
- delete_crontab_entries '#BEGIN_MUNIN_MAIN' '#END_MUNIN_MAIN'
- newsyslog
+ if [ -z "${PACKAGE_BUILDING}" ]
+ then
+ delete_crontab_entries '#BEGIN_MUNIN_MAIN' '#END_MUNIN_MAIN'
+ newsyslog
fi
;;
POST-DEINSTALL)
diff --git a/sysutils/munin-master/pkg-install b/sysutils/munin-master/pkg-install
index b6b9fe42a75c..c4b36f0b54ce 100644
--- a/sysutils/munin-master/pkg-install
+++ b/sysutils/munin-master/pkg-install
@@ -1,14 +1,17 @@
#! /bin/sh
+# ex:sw=4 sts=4
ask() {
local question default answer
question=$1
default=$2
- if [ -z "${PACKAGE_BUILDING}" -a -z "${BATCH}" ]; then
+ if [ -z "${PACKAGE_BUILDING}" -a -z "${BATCH}" ]
+ then
read -p "${question} [${default}]? " answer
fi
- if [ x${answer} = x ]; then
+ if [ x${answer} = x ]
+ then
answer=${default}
fi
echo ${answer}
@@ -34,32 +37,33 @@ create_crontab_entries() {
b=$1
e=$2
- if crontab -u munin -l > /dev/null 2>&1; then
- TMPFILE=`mktemp -t munin` || exit 1
- cat > $TMPFILE
- crontab -u munin -l | sed -e "/^$b$/,/^$e$/d" | \
- cat - $TMPFILE | crontab -u munin -
- rm $TMPFILE
+ if crontab -u munin -l > /dev/null 2>&1
+ then
+ if ! crontab -u munin -l | grep -q MANUAL_MUNIN_CRONTAB
+ then
+ TMPFILE=`mktemp -t munin` || exit 1
+ cat > $TMPFILE
+ crontab -u munin -l | sed -e "/^$b$/,/^$e$/d" | \
+ cat - $TMPFILE | crontab -u munin -
+ rm $TMPFILE
+ fi
else
crontab -u munin -
fi
}
-mklogdir() {
-}
-
newsyslog() {
- if fgrep -q '/var/log/munin/*' /etc/newsyslog.conf; then
- :
- else
+ if ! fgrep -q '/var/log/munin/*' /etc/newsyslog.conf
+ then
cat >> /etc/newsyslog.conf <<EOT
/var/log/munin/*.log munin:munin 644 7 * @T00 GNWZ
EOT
- fi
+ fi
}
move_www_dir() {
- if [ -d ${PKG_PREFIX}/www/data/munin -a ! -d ${PKG_PREFIX}/www/munin ]; then
+ if [ -d ${PKG_PREFIX}/www/data/munin -a ! -d ${PKG_PREFIX}/www/munin ]
+ then
echo Migrating ${PKG_PREFIX}/www/data/munin to ${PKG_PREFIX}/www/munin
mv ${PKG_PREFIX}/www/data/munin ${PKG_PREFIX}/www/munin
fi
@@ -71,11 +75,12 @@ move_www_dir() {
case $2 in
PRE-INSTALL)
move_www_dir # at some point in the installation, the www dir is created
- ;;
+ ;;
POST-INSTALL)
- if [ -z "${PACKAGE_BUILDING}" ]; then
- newsyslog
- create_crontab_entries '#BEGIN_MUNIN_MAIN' '#END_MUNIN_MAIN' <<EOT
+ if [ -z "${PACKAGE_BUILDING}" ]
+ then
+ newsyslog
+ create_crontab_entries '#BEGIN_MUNIN_MAIN' '#END_MUNIN_MAIN' <<EOT
#BEGIN_MUNIN_MAIN
MAILTO=root
@@ -83,5 +88,5 @@ MAILTO=root
#END_MUNIN_MAIN
EOT
fi
- ;;
+ ;;
esac