aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/p5-mogilefs-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/p5-mogilefs-server/Makefile')
-rw-r--r--sysutils/p5-mogilefs-server/Makefile39
1 files changed, 29 insertions, 10 deletions
diff --git a/sysutils/p5-mogilefs-server/Makefile b/sysutils/p5-mogilefs-server/Makefile
index 5392dced47d3..d533a31e7642 100644
--- a/sysutils/p5-mogilefs-server/Makefile
+++ b/sysutils/p5-mogilefs-server/Makefile
@@ -6,34 +6,53 @@
#
PORTNAME= mogilefs-server
-PORTVERSION= 2.17
-PORTREVISION= 1
+PORTVERSION= 2.30
CATEGORIES= sysutils perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= ../../authors/id/B/BR/BRADFITZ
+MASTER_SITE_SUBDIR= ../../authors/id/D/DO/DORMANDO
PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= MogileFS (distributed filesystem) server
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IO/AIO.pm:${PORTSDIR}/devel/p5-IO-AIO \
+ ${SITE_PERL}/${PERL_ARCH}/Sys/Syslog.pm:${PORTSDIR}/sysutils/p5-Sys-Syslog \
${SITE_PERL}/Danga/Socket.pm:${PORTSDIR}/devel/p5-Danga-Socket \
${SITE_PERL}/Gearman/Client/Async.pm:${PORTSDIR}/devel/p5-Gearman-Client-Async \
${SITE_PERL}/Gearman/Server.pm:${PORTSDIR}/devel/p5-Gearman-Server \
+ ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
${SITE_PERL}/Perlbal.pm:${PORTSDIR}/www/perlbal \
${SITE_PERL}/Sys/Syscall.pm:${PORTSDIR}/devel/p5-Sys-Syscall
PERL_CONFIGURE= yes
-MAN1= mogautomount.1 mogilefsd.1 mogstored.1
-MAN3= MogileFS::DevFID.3 MogileFS::FID.3 MogileFS::IOStatWatcher.3 \
- MogileFS::Overview.3 MogileFS::ReplicationPolicy.3 \
+MAN1= mogautomount.1 \
+ mogilefsd.1 \
+ mogstored.1
+MAN3= MogileFS::DevFID.3 \
+ MogileFS::FID.3 \
+ MogileFS::IOStatWatcher.3 \
+ MogileFS::Overview.3 \
+ MogileFS::ReplicationPolicy.3 \
MogileFS::ReplicationPolicy::MultipleHosts.3 \
- MogileFS::Server.3 MogileFS::Store.3 \
- MogileFS::Store::MySQL.3 MogileFS::Store::SQLite.3 \
- MogileFS::Worker::Query.3 MogileFS::Worker::Replicate.3 \
- MogileFS::Store::Postgres.3
+ MogileFS::ReplicationPolicy::Union.3 \
+ MogileFS::Server.3 \
+ MogileFS::Store.3 \
+ MogileFS::Store::MySQL.3 \
+ MogileFS::Store::Postgres.3 \
+ MogileFS::Store::SQLite.3 \
+ MogileFS::Worker::Query.3 \
+ MogileFS::Worker::Replicate.3 \
+ mogdeps::Danga::Socket.3 \
+ mogdeps::Gearman::Client.3 \
+ mogdeps::Gearman::Client::Async.3 \
+ mogdeps::Gearman::Server.3 \
+ mogdeps::Gearman::Server::Client.3 \
+ mogdeps::Gearman::Task.3 \
+ mogdeps::Gearman::Worker.3 \
+ mogdeps::Perlbal.3 \
+ mogdeps::Sys::Syscall.3
post-install:
.ifndef(NOPORTDOCS)