aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/py-pywatchman/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/py-pywatchman/Makefile')
-rw-r--r--sysutils/py-pywatchman/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/sysutils/py-pywatchman/Makefile b/sysutils/py-pywatchman/Makefile
new file mode 100644
index 000000000000..35519dfa0dc6
--- /dev/null
+++ b/sysutils/py-pywatchman/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= pywatchman
+PORTVERSION= 1.3.0
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= linpct@gmail.com
+COMMENT= Watchman client for Python
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= watchman>=4:${PORTSDIR}/sysutils/watchman
+
+USES= python:2
+USE_PYTHON= autoplist distutils
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} \
+ -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>