aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/py-tmuxp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/py-tmuxp/Makefile')
-rw-r--r--sysutils/py-tmuxp/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/sysutils/py-tmuxp/Makefile b/sysutils/py-tmuxp/Makefile
index 00141d00a723..a32e685f24d0 100644
--- a/sysutils/py-tmuxp/Makefile
+++ b/sysutils/py-tmuxp/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tmuxp
-PORTVERSION= 0.9.3
+DISTVERSION= 1.3.5
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,13 +13,14 @@ COMMENT= Session manager for tmux
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}argcomplete>=0:devel/py-argcomplete@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}kaptan>=0.5.7:devel/py-kaptan@${FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}colorama>=0.3.3:devel/py-colorama@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}kaptan>=0.5.7:devel/py-kaptan@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}libtmux>0:devel/py-libtmux@${FLAVOR} \
tmux:sysutils/tmux
-NO_ARCH= yes
USES= python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= distutils concurrent autoplist
+NO_ARCH= yes
.include <bsd.port.mk>