aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/qjail2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/qjail2/Makefile')
-rw-r--r--sysutils/qjail2/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/qjail2/Makefile b/sysutils/qjail2/Makefile
new file mode 100644
index 000000000000..03312bc072f0
--- /dev/null
+++ b/sysutils/qjail2/Makefile
@@ -0,0 +1,44 @@
+# Created by: Joe Barbish
+# $FreeBSD$
+
+PORTNAME= qjail
+PORTVERSION= 2.2
+CATEGORIES= sysutils
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= qjail@a1poweruser.com
+COMMENT= Utility to quickly deploy and manage jails
+
+USE_BZIP2= yes
+NO_BUILD= yes
+LATEST_LINK= ${PORTNAME}2
+
+MAN8= qjail.8 qjail-intro.8 qjail.conf.8 qjail-howto.8
+
+CONFLICTS_INSTALL= qjail-3.*
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|/usr/local|${PREFIX}|'
+ @${FIND} ${WRKSRC}/examples -name '*.bak' -delete
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/qjail ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/qjail2 ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${WRKSRC}/qjail-jail2 ${PREFIX}/etc/rc.d
+ @${INSTALL_DATA} ${WRKSRC}/qjail.conf.sample ${PREFIX}/etc
+ @${INSTALL_DATA} ${WRKSRC}/qjail.portsnap.conf ${PREFIX}/etc
+.for i in qjail qjail-intro qjail.conf qjail-howto
+ @${INSTALL_MAN} ${WRKSRC}/${i}.8 ${MAN8PREFIX}/man/man8
+.endfor
+# note examples are mandatory. qjail will not function without them
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples/ \
+ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+
+post-install:
+ @${ECHO_MSG} "#"
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} "#"
+
+.include <bsd.port.mk>
class='deletions'>-2/+2 * - Update to 2.4a2perky2004-08-071-2/+2 * The tarball for Python 2.4a1 is renamed in the site.perky2004-07-101-2/+2 * - Update to 2.4a1, the first alpha release of Python 2.4.perky2004-07-081-2/+2 * Update to Python development snapshot as of 040311.perky2004-03-111-1/+2 * Add missed deltas on 2.4 040106 update.perky2004-01-091-1/+1 * - Update lang/python-devel to Python-2.4 031022 snapshot.perky2003-10-301-1/+1 * Update to 2.4a0 snapshot of 1 Aug 2003perky2003-08-011-1/+1 * Update to 2.3c1perky2003-07-191-1/+1 * Update new python-devel port to 2.3.b2.perky2003-07-031-1/+1