aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/rubygem-fluentd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/rubygem-fluentd/Makefile')
-rw-r--r--sysutils/rubygem-fluentd/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/sysutils/rubygem-fluentd/Makefile b/sysutils/rubygem-fluentd/Makefile
index 33264d3de4a1..60cbc754790b 100644
--- a/sysutils/rubygem-fluentd/Makefile
+++ b/sysutils/rubygem-fluentd/Makefile
@@ -1,12 +1,7 @@
-# New ports collection makefile for: rubygem-fluentd
-# Date created: 10 Jul 2012
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= fluentd
-PORTVERSION= 0.10.25
+PORTVERSION= 0.10.27
CATEGORIES= sysutils rubygems
MASTER_SITES= RG
@@ -23,8 +18,14 @@ RUN_DEPENDS= \
USE_RUBY= yes
#RUBY_VER= 1.9 # Please set RUBY_DEFAULT_VER=1.9 in /etc/make.conf
USE_RUBYGEMS= yes
-PLIST_FILES= bin/fluent-cat bin/fluent-gem bin/fluentd
+PLIST_FILES= bin/fluent-cat bin/fluent-debug bin/fluent-gem bin/fluentd \
+ "@exec ${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 775 /var/run/fluentd" \
+ "@unexec ${RMDIR} /var/run/fluentd 2>/dev/null || true"
RUBYGEM_AUTOPLIST= yes
+USE_RC_SUBR= fluentd
+USERS= fluentd
+GROUPS= fluentd
+SUB_LIST+= USER=${USERS} GROUP=${GROUPS}
.include <bsd.port.pre.mk>
@@ -32,4 +33,7 @@ RUBYGEM_AUTOPLIST= yes
IGNORE= requires Ruby 1.9, please install this first
.endif
+post-install:
+ ${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 775 /var/run/fluentd
+
.include <bsd.port.post.mk>