aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/scanbuttond/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/scanbuttond/Makefile')
-rw-r--r--sysutils/scanbuttond/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/sysutils/scanbuttond/Makefile b/sysutils/scanbuttond/Makefile
new file mode 100644
index 000000000000..02dc44f2eb73
--- /dev/null
+++ b/sysutils/scanbuttond/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: scanbuttond
+# Date created: 31 March 2006
+# Whom: Daniel Thiele
+#
+# $FreeBSD$
+#
+
+PORTNAME= scanbuttond
+PORTVERSION= 0.2.3
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= dthiele@gmx.net
+COMMENT= A daemon to monitor and configure modern scanner's buttons
+
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+INSTALLS_SHLIB= yes
+
+SUB_FILES+= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not build
+.endif
+
+pre-configure:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|-ldl||g'
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>