aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/synergy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/synergy/Makefile')
-rw-r--r--sysutils/synergy/Makefile25
1 files changed, 19 insertions, 6 deletions
diff --git a/sysutils/synergy/Makefile b/sysutils/synergy/Makefile
index 4e3d2e67c7e3..1fa5bbf35b73 100644
--- a/sysutils/synergy/Makefile
+++ b/sysutils/synergy/Makefile
@@ -1,11 +1,11 @@
# $FreeBSD$
PORTNAME= synergy
-PORTVERSION= 1.3.8
-PORTREVISION= 1
+PORTVERSION= 1.5.0
DISTVERSIONSUFFIX= -Source
CATEGORIES= sysutils
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= http://synergy-project.org/files/packages/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-r2278${DISTVERSIONSUFFIX}
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Mouse and keyboard sharing utility
@@ -13,21 +13,34 @@ COMMENT= Mouse and keyboard sharing utility
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}${DISTVERSIONSUFFIX}
USES= cmake
USE_XORG= ice xtst x11 sm
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+
MAKE_JOBS_UNSAFE=yes
-CFLAGS+= -L${LOCALBASE}/lib -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-PLIST_FILES= bin/synergys bin/synergyc
+PLIST_FILES= bin/synergyc bin/synergyd bin/synergys bin/syntool \
+ man/man1/synergyc.1.gz man/man1/synergys.1.gz
PORTEXAMPLES= synergy.conf.example synergy.conf.example-basic \
synergy.conf.example-advanced
+post-extract:
+ cd ${WRKSRC}/ext/
+ ${MKDIR} ${WRKSRC}/ext/cryptopp562
+ (cd ${WRKSRC}/ext/cryptopp562 && ${TAR} xfz ${WRKSRC}/ext/cryptopp562.zip)
+
do-install:
-.for f in synergys synergyc
+.for f in synergyc synergyd synergys syntool
${INSTALL_PROGRAM} ${WRKSRC}/bin/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
+ ${INSTALL_MAN} ${WRKSRC}/doc/synergyc.man \
+ ${STAGEDIR}${MANPREFIX}/man/man1/synergyc.1
+ ${INSTALL_MAN} ${WRKSRC}/doc/synergys.man \
+ ${STAGEDIR}${MANPREFIX}/man/man1/synergys.1
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in ${PORTEXAMPLES}