aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/tracker/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/tracker/Makefile')
-rw-r--r--sysutils/tracker/Makefile130
1 files changed, 46 insertions, 84 deletions
diff --git a/sysutils/tracker/Makefile b/sysutils/tracker/Makefile
index 96e0a220ec4e..f27e4744698b 100644
--- a/sysutils/tracker/Makefile
+++ b/sysutils/tracker/Makefile
@@ -1,10 +1,8 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/sysutils/tracker/Makefile 20045 2014-11-10 06:23:59Z gusi $
PORTNAME= tracker
-PORTVERSION= 1.2.6
-PORTREVISION= 4
+PORTVERSION= 1.4.1
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
@@ -17,28 +15,29 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libraptor.so:${PORTSDIR}/textproc/raptor \
libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
libicutu.so:${PORTSDIR}/devel/icu \
- libmediaart-1.0.so:${PORTSDIR}/multimedia/libmediaart \
+ libmediaart-2.0.so:${PORTSDIR}/multimedia/libmediaart \
librest-0.7.so:${PORTSDIR}/devel/librest
RUN_DEPENDS= xdg-desktop-icon:${PORTSDIR}/devel/xdg-utils \
o3totxt:${PORTSDIR}/converters/o3read \
pdftotext:${PORTSDIR}/graphics/poppler-utils \
w3m:${PORTSDIR}/www/w3m
-PLIST_SUB= TRACKER_VER="1.0"
+PORTSCOUT= limitw:1,even
-USES= gettext gmake libarchive libtool pathfix pkgconfig tar:xz
-USE_GNOME= gnomeprefix gtk30 intlhack introspection:build
+USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= gtk30 intltool introspection:build libxslt:build
USE_LDCONFIG= yes
USE_SQLITE= 3
USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/tracker
-CONFIGURE_ARGS= --enable-video-extractor=gstreamer \
- --with-session-bus-services-dir=${LOCALBASE}/share/dbus-1/services \
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --with-session-bus-services-dir=${LOCALBASE}/share/dbus-1/services \
--disable-libiptcdata --enable-miner-fs \
- --disable-meegotouch --disable-miner-flickr \
+ --disable-meegotouch \
--enable-icu-charset-detection \
+ --disable-network-manager \
--disable-enca \
--enable-tracker-preferences \
--disable-libosinfo \
@@ -55,86 +54,49 @@ GLIB_SCHEMAS= org.freedesktop.Tracker.DB.gschema.xml \
org.freedesktop.Tracker.enums.xml \
org.freedesktop.Tracker.gschema.xml
-OPTIONS_DEFINE= AUDIO_MINERS DOCUMENT_MINERS GRAPHIC_MINERS WEB_MINERS
+PLIST_SUB= TRACKER_VER="1.0" LIBVER=400
+
+OPTIONS_DEFINE= AUDIO_MINERS DOCUMENT_MINERS GRAPHIC_MINERS \
+ NAUTILUS WEB_MINERS
OPTIONS_DEFAULT= AUDIO_MINERS DOCUMENT_MINERS GRAPHIC_MINERS
-WEB_MINERS_DESC= Support for Firefox, Thunderbird and Evolution
+OPTIONS_SUB=yes
+WEB_MINERS_DESC= Support for Firefox, Thunderbird
+# and Evolution
AUDIO_MINERS_DESC= Support for audio formats
DOCUMENT_MINERS_DESC= Support for some sort of documents (pdf, ps, xps, office)
GRAPHIC_MINERS_DESC= Support for some graphic formats (gif, png, tiff)
+NAUTILUS_DESC= Support for nautilus tagging
-.include <bsd.port.pre.mk>
+WEB_MINERS_CONFIGURE_ENABLE= miner-firefox miner-thunderbird
+# miner-evolution
+WEB_MINERS_BUILD_DEPENDS= firefox>=0:${PORTSDIR}/www/firefox \
+ thunderbird>=0:${PORTSDIR}/mail/thunderbird
+WEB_MINERS_RUN_DEPENDS= firefox>=0:${PORTSDIR}/www/firefox \
+ thunderbird>=0:${PORTSDIR}/mail/thunderbird
-.if ${PORT_OPTIONS:MWEB_MINERS}
-CONFIGURE_ARGS+= --enable-miner-firefox \
- --enable-miner-thunderbird
-BUILD_DEPENDS+= firefox>=0:${PORTSDIR}/www/firefox \
- thunderbird>=0:${PORTSDIR}/mail/thunderbird
-RUN_DEPENDS+= firefox>=0:${PORTSDIR}/www/firefox \
- thunderbird>=0:${PORTSDIR}/mail/thunderbird
-PLIST_SUB+= WEB_MINERS=""
-.else
-CONFIGURE_ARGS+= --disable-miner-evolution --disable-miner-firefox \
- --disable-miner-thunderbird
-PLIST_SUB+= WEB_MINERS="@comment "
-.endif
+AUDIO_MINERS_CONFIGURE_ENABLE= libvorbis libflac taglib mp3 libcue playlist
+AUDIO_MINERS_LIB_DEPENDS= libtotem-plparser.so:${PORTSDIR}/multimedia/totem-pl-parser \
+ libFLAC.so:${PORTSDIR}/audio/flac \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libcue.so:${PORTSDIR}/textproc/libcue \
+ libogg.so:${PORTSDIR}/audio/libogg \
+ libtag.so:${PORTSDIR}/audio/taglib
-.if ${PORT_OPTIONS:MAUDIO_MINERS}
-LIB_DEPENDS+= libtotem-plparser.so:${PORTSDIR}/multimedia/totem-pl-parser \
- libFLAC.so:${PORTSDIR}/audio/flac \
- libvorbis.so:${PORTSDIR}/audio/libvorbis \
- libcue.so:${PORTSDIR}/textproc/libcue \
- libogg.so:${PORTSDIR}/audio/libogg \
- libtag.so:${PORTSDIR}/audio/taglib
-CONFIGURE_ARGS+= --enable-libvorbis --enable-libflac \
- --enable-taglib --enable-mp3 \
- --enable-libcue --enable-playlist
-PLIST_SUB+= AUDIO_MINERS=""
-.else
-CONFIGURE_ARGS+= --disable-libvorbis --disable-libflac \
- --disable-taglib --disable-mp3 \
- --disable-libcue --disable-playlist
-PLIST_SUB+= AUDIO_MINERS="@comment "
-.endif
+DOCUMENT_MINERS_CONFIGURE_ENABLE= libgxps poppler libxml2 libgsf \
+ abiword dvi ps exempi text
+DOCUMENT_MINERS_LIB_DEPENDS= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib \
+ libgxps.so:${PORTSDIR}/graphics/libgxps \
+ libgsf-1.so:${PORTSDIR}/devel/libgsf \
+ libexempi.so:${PORTSDIR}/textproc/exempi \
+ libwv.so:${PORTSDIR}/textproc/wv
-.if ${PORT_OPTIONS:MDOCUMENT_MINERS}
-LIB_DEPENDS+= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib \
- libgxps.so:${PORTSDIR}/graphics/libgxps \
- libgsf-1.so:${PORTSDIR}/devel/libgsf \
- libexempi.so:${PORTSDIR}/textproc/exempi \
- libwv.so:${PORTSDIR}/textproc/wv
-CONFIGURE_ARGS+= --enable-libgxps --enable-poppler \
- --enable-libxml2 --enable-exif \
- --enable-libgsf --enable-abiword \
- --enable-dvi --enable-ps \
- --enable-exempi --enable-text
-PLIST_SUB+= DOCUMENT_MINERS=""
-.else
-CONFIGURE_ARGS+= --disable-libgxps --disable-poppler \
- --disable-libxml2 --disable-exif \
- --disable-libgsf --disable-abiword \
- --disable-dvi --disable-ps \
- --disable-exempi --disable-text
-PLIST_SUB+= DOCUMENT_MINERS="@comment "
-.endif
+GRAPHIC_MINERS_CONFIGURE_ENABLE= libexif libgif libjpeg libtiff icon libpng
+GRAPHIC_MINERS_LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif \
+ libgif.so:${PORTSDIR}/graphics/giflib \
+ libpng.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
-.if ${PORT_OPTIONS:MGRAPHIC_MINERS}
-LIB_DEPENDS+= libexif.so:${PORTSDIR}/graphics/libexif \
- libgif.so:${PORTSDIR}/graphics/giflib \
- libpng.so:${PORTSDIR}/graphics/png \
- libtiff.so:${PORTSDIR}/graphics/tiff
-CONFIGURE_ARGS+= --enable-libgif \
- --enable-libjpeg \
- --enable-libtiff \
- --enable-icon \
- --enable-libpng15
-PLIST_SUB+= GRAPHIC_MINERS=""
-.else
-CONFIGURE_ARGS+= --disable-libgif \
- --disable-libjpeg \
- --disable-libtiff \
- --disable-icon \
- --disable-libpng15
-PLIST_SUB+= GRAPHIC_MINERS="@comment "
-.endif
+NAUTILUS_CONFIGURE_ENABLE= nautilus-extension
+NAUTILUS_USE= GNOME=nautilus3
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>