aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/u-boot-sinovoip-bpi-m3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/u-boot-sinovoip-bpi-m3/Makefile')
-rw-r--r--sysutils/u-boot-sinovoip-bpi-m3/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/u-boot-sinovoip-bpi-m3/Makefile b/sysutils/u-boot-sinovoip-bpi-m3/Makefile
new file mode 100644
index 000000000000..c48e607992f1
--- /dev/null
+++ b/sysutils/u-boot-sinovoip-bpi-m3/Makefile
@@ -0,0 +1,53 @@
+# $FreeBSD$
+
+PORTNAME= u-boot
+PORTVERSION= 2016.05
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.denx.de/pub/u-boot/
+PKGNAMESUFFIX?= -sinovoip-bpi-m3
+
+MAINTAINER= jmcneill@FreeBSD.org
+COMMENT= Cross-build U-Boot loader for Sinovoip Banana Pi M3
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= arm-none-eabi-gcc:devel/arm-none-eabi-gcc
+
+USES= gmake tar:bzip2
+WRKSRC= ${WRKDIR}/u-boot-${DISTVERSION}
+
+.include <bsd.port.pre.mk>
+NO_ARCH= yes
+.if ${OSVERSION} < 1001000
+IGNORE= requires dtc
+.endif
+
+MODEL?= sinovoip-bpi-m3
+CONF_TARGET?= Sinovoip_BPI_M3_defconfig
+
+SSP_UNSAFE= yes # cross-LD does not support -fstack-protector
+
+U_BOOT_DIR= share/u-boot/${PORTNAME}${PKGNAMESUFFIX}
+PLIST_FILES= ${U_BOOT_DIR}/u-boot.img \
+ ${U_BOOT_DIR}/u-boot-sunxi-with-spl.bin \
+ ${U_BOOT_DIR}/sunxi-spl.bin \
+ ${U_BOOT_DIR}/README
+
+MAKE_ARGS+= ARCH=arm \
+ CROSS_COMPILE=arm-none-eabi-
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%MODEL%%,${MODEL}," \
+ ${WRKSRC}/include/configs/sunxi-common.h
+
+do-configure:
+ (cd ${WRKSRC}; ${GMAKE} ${CONF_TARGET})
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
+ ${CP} ${WRKSRC}/spl/sunxi-spl.bin ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
+ ${CP} ${WRKSRC}/u-boot-sunxi-with-spl.bin ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
+ ${CP} ${WRKSRC}/u-boot.img ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
+ ${CP} ${.CURDIR}/pkg-descr ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}/README
+
+.include <bsd.port.post.mk>