aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/weedit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/weedit/Makefile')
-rw-r--r--sysutils/weedit/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/sysutils/weedit/Makefile b/sysutils/weedit/Makefile
new file mode 100644
index 000000000000..999a70c1e022
--- /dev/null
+++ b/sysutils/weedit/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: weedit
+# Date created: 9 Oct 2007
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weedit
+PORTVERSION= 2.0.1
+CATEGORIES= sysutils
+MASTER_SITES= http://adm1n.cjb.net/cw/ \
+ http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= File duplicate scanner with database support
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+SRCF= crc32 dlink weedit md5
+
+PLIST_FILES= bin/weedit bin/weeditreaddb
+
+do-build:
+.for f in ${SRCF}
+ ${CC} ${CFLAGS} -c ${WRKSRC}/${f}.c -o ${WRKSRC}/${f}.o
+.endfor
+ ${CC} ${CFLAGS} ${WRKSRC}/utils/readdb.c -o ${WRKSRC}/weeditreaddb
+ ${CC} ${LDFLAGS} -o ${WRKSRC}/${PORTNAME} \
+ ${SRCF:C/(.*)/${WRKSRC}\/\1.o/}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/weeditreaddb ${PREFIX}/bin
+
+.include <bsd.port.mk>