aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/wmbattery/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/wmbattery/Makefile')
-rw-r--r--sysutils/wmbattery/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/sysutils/wmbattery/Makefile b/sysutils/wmbattery/Makefile
new file mode 100644
index 000000000000..d127ed30b328
--- /dev/null
+++ b/sysutils/wmbattery/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: wmbattery
+# Version required: 1.9
+# Date created: 18 Sep 1999
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= wmbattery
+PKGNAME= ${DISTNAME}-1.9
+CATEGORIES= sysutils
+MASTER_SITES= http://kitenet.net/programs/code/wmbattery/
+
+MAINTAINER= andrews@technologist.com
+
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+
+USE_X_PREFIX= yes
+
+USE_GMAKE= YES
+MAKE_ENV= PREFIX="${PREFIX}" INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_DATA="${INSTALL_DATA}" INSTALL_MAN="${INSTALL_MAN}"
+ALL_TARGET= wmbattery
+MAN1= wmbattery.1
+
+# install additional docs
+.if !defined(NOPORTDOCS)
+post-install:
+.for i in COPYING INSTALL README TODO
+ @${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/wmbattery
+.endfor
+.endif
+
+.include <bsd.port.mk>