aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/wmbluecpu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/wmbluecpu/Makefile')
-rw-r--r--sysutils/wmbluecpu/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/wmbluecpu/Makefile b/sysutils/wmbluecpu/Makefile
new file mode 100644
index 000000000000..e1a02059010e
--- /dev/null
+++ b/sysutils/wmbluecpu/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: wmbluecpu
+# Date created: 29 Mar 2003
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmbluecpu
+PORTVERSION= 0.4
+CATEGORIES= sysutils windowmaker
+MASTER_SITES= http://ibiblio.org/pub/linux/X11/xutils/ \
+ ftp://ftp.ibiblio.org/pub/linux/X11/xutils/
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= A CPU monitoring dockapp
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_XPM= yes
+
+MAN1= wmbluecpu.1
+
+post-patch:
+ @${CP} ${FILESDIR}/cpu_freebsd.* ${WRKSRC}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${CHMOD} g+s ${PREFIX}/bin/${PORTNAME}
+ @${CHOWN} root:kmem ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>