aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/xfce4-netload-plugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/xfce4-netload-plugin/Makefile')
-rw-r--r--sysutils/xfce4-netload-plugin/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/sysutils/xfce4-netload-plugin/Makefile b/sysutils/xfce4-netload-plugin/Makefile
index 72b5632ad040..a080015291a3 100644
--- a/sysutils/xfce4-netload-plugin/Makefile
+++ b/sysutils/xfce4-netload-plugin/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-netload-plugin
-PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTVERSION= 1.2.2
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -13,24 +12,21 @@ MAINTAINER= demon@FreeBSD.org
COMMENT= Network Load plugin for Xfce4
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
USE_GNOME= intltool intlhack
USE_XFCE= configenv libmenu panel
-USES= gmake pkgconfig tar:bzip2
+USES= gmake pkgconfig libtool tar:bzip2
INSTALLS_ICONS= yes
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-.else
-CONFIGURE_ARGS+=--disable-nls
-.endif
+.include <bsd.port.options.mk>
do-patch:
@${REINPLACE_CMD} -e 's, || __FreeBSD_kernel__,,' \
@@ -38,8 +34,12 @@ do-patch:
${WRKSRC}/panel-plugin/net.h \
${WRKSRC}/panel-plugin/os.h
-.if empty(PORT_OPTIONS:MNLS)
- @${REINPLACE_CMD} -e 's|po ||' ${WRKSRC}/Makefile.in
+.if ${PORT_OPTIONS:MNLS}
+ ${REINPLACE_CMD} -e \
+ 's|$$(prefix)/$$(DATADIRNAME)/locale|$$(datarootdir)/locale|' \
+ ${WRKSRC}/po/Makefile.in.in
+.else
+ ${REINPLACE_CMD} -e 's|po ||' ${WRKSRC}/Makefile.in
.endif
.include <bsd.port.mk>