aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/clone/Makefile8
-rw-r--r--sysutils/clone/distinfo4
-rw-r--r--sysutils/clone/files/patch-Makefile13
3 files changed, 18 insertions, 7 deletions
diff --git a/sysutils/clone/Makefile b/sysutils/clone/Makefile
index 84df3f43d498..6950bd9a4811 100644
--- a/sysutils/clone/Makefile
+++ b/sysutils/clone/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= clone
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.3
CATEGORIES= sysutils
MASTER_SITES= GOOGLE_CODE
@@ -10,9 +10,7 @@ COMMENT= File tree cloning tool
LICENSE= BSD
-PLIST_FILES= bin/clone
+PLIST_FILES= bin/clone \
+ man/man1/clone.1.gz
-MAN1= clone.1
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/sysutils/clone/distinfo b/sysutils/clone/distinfo
index 91935261b910..7b8da5f6b44c 100644
--- a/sysutils/clone/distinfo
+++ b/sysutils/clone/distinfo
@@ -1,2 +1,2 @@
-SHA256 (clone-1.0.2.tar.gz) = c6ed6a6a47fb9ae9ebb897fe5cea2d283be02702506b582beeb58fa4d1c17588
-SIZE (clone-1.0.2.tar.gz) = 23174
+SHA256 (clone-1.0.3.tar.gz) = fe4cb2331c1bfa69a0ef4a403b6b03546127321824ca8f99b6207ed6dc4889a0
+SIZE (clone-1.0.3.tar.gz) = 25620
diff --git a/sysutils/clone/files/patch-Makefile b/sysutils/clone/files/patch-Makefile
new file mode 100644
index 000000000000..3991f622891f
--- /dev/null
+++ b/sysutils/clone/files/patch-Makefile
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- Makefile.orig
++++ Makefile
+@@ -60,5 +60,5 @@
+ update: clean all
+
+ install: $(TOOL)
+- strip -x -o /usr/local/bin/$(TOOL) $(TOOL)
+- cp $(TOOL).1 /usr/local/man/man1/$(TOOL).1
++ strip -x -o $(DESTDIR)$(PREFIX)/bin/$(TOOL) $(TOOL)
++ cp $(TOOL).1 $(DESTDIR)$(PREFIX)/man/man1/$(TOOL).1