aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/file/Makefile1
-rw-r--r--sysutils/file/files/patch-src__readcdf.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/file/Makefile b/sysutils/file/Makefile
index b169274bfa2f..cc427782f12f 100644
--- a/sysutils/file/Makefile
+++ b/sysutils/file/Makefile
@@ -7,6 +7,7 @@
PORTNAME= file
PORTVERSION= 5.03
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.astron.com/pub/file/ \
ftp://ftp.gw.com/mirrors/unix/file/ \
diff --git a/sysutils/file/files/patch-src__readcdf.c b/sysutils/file/files/patch-src__readcdf.c
new file mode 100644
index 000000000000..1e71ca1bb0c2
--- /dev/null
+++ b/sysutils/file/files/patch-src__readcdf.c
@@ -0,0 +1,11 @@
+--- ./src/readcdf.c.orig 2010-01-14 16:30:22.699632246 -0500
++++ ./src/readcdf.c 2010-01-14 16:30:27.240264949 -0500
+@@ -100,6 +100,8 @@
+ str = "vnd.ms-excel";
+ else if (strstr(s, "Powerpoint"))
+ str = "vnd.ms-powerpoint";
++ else if (strstr(s, "Crystal Reports"))
++ str = "x-rpt";
+ }
+ }
+ break;