aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/tmpwatch/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/sysutils/tmpwatch/Makefile b/sysutils/tmpwatch/Makefile
index a1913071e502..1346053b38bb 100644
--- a/sysutils/tmpwatch/Makefile
+++ b/sysutils/tmpwatch/Makefile
@@ -23,6 +23,8 @@ CFLAGS+= ${CPPFLAGS} -DVERSION=\"${PORTVERSION}\"
MAN8= tmpwatch.8
PLIST_FILES= sbin/tmpwatch
+.include <bsd.port.pre.mk>
+
do-extract:
${MKDIR} ${WRKDIR}
cd ${WRKDIR} && \
@@ -33,6 +35,10 @@ do-extract:
post-patch:
${REINPLACE_CMD} -E "s/^#include.+mntent.h.+//g" ${WRKSRC}/tmpwatch.c
+.if ${OSVERSION} < 500000
+ ${REINPLACE_CMD} -E "s/intmax_t/long long/;s/strtoimax/strtoll/" \
+ ${WRKSRC}/tmpwatch.c
+.endif
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} ${LDFLAGS} -o tmpwatch tmpwatch.c
@@ -41,4 +47,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tmpwatch ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/tmpwatch.8 ${MAN8PREFIX}/man/man8
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>