aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/acpica-tools/Makefile10
-rw-r--r--sysutils/acpica-tools/distinfo4
-rw-r--r--sysutils/acpica-tools/files/patch-generate__unix__Makefile.common11
-rw-r--r--sysutils/acpica-tools/files/patch-source__include__platform__acfreebsd.h33
4 files changed, 7 insertions, 51 deletions
diff --git a/sysutils/acpica-tools/Makefile b/sysutils/acpica-tools/Makefile
index ca9cf973d109..26944ea23eef 100644
--- a/sysutils/acpica-tools/Makefile
+++ b/sysutils/acpica-tools/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= acpica
-PORTVERSION= 20130626
+PORTVERSION= 20130725
CATEGORIES= sysutils devel
MASTER_SITES= https://acpica.org/sites/acpica/files/ \
LOCAL
@@ -15,7 +15,7 @@ COMMENT= Tools from the ACPI Component Architecture (ACPICA) project
LICENSE= BSD
USE_GMAKE= yes
-MAKE_ARGS= HOST=_FreeBSD
+MAKE_ARGS= HOST=_FreeBSD INSTALLFLAGS="${INSTALL_PROGRAM:S/^${INSTALL}//}"
WRKSRC_SUBDIR= generate/unix
LFLAGS= -i -s
YFLAGS= -v -d
@@ -25,11 +25,11 @@ YFLAGS+= -y
post-patch:
@${REINPLACE_CMD} -e 's|^CC[[:blank:]]*=.*|CC = ${CC}|' \
- -e 's|INSTALLPROG = install -D|INSTALLPROG = ${INSTALL_PROGRAM}|' \
+ -e 's|^INSTALL[[:blank:]]*=.*|INSTALL = ${INSTALL}|g' \
-e 's|^LEX[[:blank:]]*=.*|LEX = ${FLEX}|' \
- -e 's|^LFLAGS[[:blank:]]*+=.*|LFLAGS = ${LFLAGS}|' \
+ -e 's|^LFLAGS[[:blank:]]*\+=.*|LFLAGS = ${LFLAGS}|' \
-e 's|^YACC[[:blank:]]*=.*|YACC = ${YACC}|' \
- -e 's|^YFLAGS[[:blank:]]*+=.*|YFLAGS = ${YFLAGS}|' \
+ -e 's|^YFLAGS[[:blank:]]*\+=.*|YFLAGS = ${YFLAGS}|' \
${WRKSRC}/Makefile.config
.include <bsd.port.mk>
diff --git a/sysutils/acpica-tools/distinfo b/sysutils/acpica-tools/distinfo
index 39bd2d0ae97f..050eea21475e 100644
--- a/sysutils/acpica-tools/distinfo
+++ b/sysutils/acpica-tools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (acpica-unix2-20130626.tar.gz) = 888dda6227265c396a686624f971c51693c2bba84f24c634536234c8dca7b465
-SIZE (acpica-unix2-20130626.tar.gz) = 1218252
+SHA256 (acpica-unix2-20130725.tar.gz) = f31ad702a17f9dd03907693120267216d1a797625d123a38f3064fbafe141d8a
+SIZE (acpica-unix2-20130725.tar.gz) = 1221234
diff --git a/sysutils/acpica-tools/files/patch-generate__unix__Makefile.common b/sysutils/acpica-tools/files/patch-generate__unix__Makefile.common
deleted file mode 100644
index 27dc161182e0..000000000000
--- a/sysutils/acpica-tools/files/patch-generate__unix__Makefile.common
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.common.orig 2013-06-26 14:00:04.000000000 -0400
-+++ Makefile.common 2013-06-26 21:01:35.000000000 -0400
-@@ -6,7 +6,7 @@
- # Get the OS machine architecture. Anything with a "64" in the returned
- # string will be treated as a 64-bit OS. Otherwise, the default is 32-bit.
- #
--HARDWARE_NAME := $(shell uname -m)
-+HARDWARE_NAME := $(shell uname -p)
-
- #
- # Main rule will only generate versions that are appropriate for the running
diff --git a/sysutils/acpica-tools/files/patch-source__include__platform__acfreebsd.h b/sysutils/acpica-tools/files/patch-source__include__platform__acfreebsd.h
deleted file mode 100644
index 97bbe8938e14..000000000000
--- a/sysutils/acpica-tools/files/patch-source__include__platform__acfreebsd.h
+++ /dev/null
@@ -1,33 +0,0 @@
---- ../../source/include/platform/acfreebsd.h.orig 2013-06-26 14:00:12.000000000 -0400
-+++ ../../source/include/platform/acfreebsd.h 2013-06-26 20:30:30.000000000 -0400
-@@ -49,12 +49,21 @@
-
- #include "acgcc.h"
- #include <sys/types.h>
--#include <machine/acpica_machdep.h>
-+
-+#ifdef __LP64__
-+#define ACPI_MACHINE_WIDTH 64
-+#else
-+#define ACPI_MACHINE_WIDTH 32
-+#endif
-+
-+#define COMPILER_DEPENDENT_INT64 int64_t
-+#define COMPILER_DEPENDENT_UINT64 uint64_t
-
- #define ACPI_UINTPTR_T uintptr_t
-
- #define ACPI_USE_DO_WHILE_0
- #define ACPI_USE_LOCAL_CACHE
-+#define ACPI_USE_NATIVE_DIVIDE
- #define ACPI_USE_SYSTEM_CLIBRARY
-
- #ifdef _KERNEL
-@@ -63,6 +72,7 @@
- #include <sys/param.h>
- #include <sys/systm.h>
- #include <sys/libkern.h>
-+#include <machine/acpica_machdep.h>
- #include <machine/stdarg.h>
-
- #include "opt_acpi.h"