aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/u-boot-pandaboard/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/sysutils/u-boot-pandaboard/Makefile b/sysutils/u-boot-pandaboard/Makefile
index f7a1fd427280..28a03a737b53 100644
--- a/sysutils/u-boot-pandaboard/Makefile
+++ b/sysutils/u-boot-pandaboard/Makefile
@@ -11,7 +11,9 @@ COMMENT= Cross-build U-Boot loader for PandaBoard
LICENSE= GPLv2
-BUILD_DEPENDS= arm-none-eabi-gcc:${PORTSDIR}/devel/arm-none-eabi-gcc
+BUILD_DEPENDS= ${CROSS_GCC}:${PORTSDIR}/devel/arm-none-eabi-gcc492
+
+CROSS_GCC= arm-none-eabi-gcc-4.9.2
NO_ARCH= yes
@@ -25,6 +27,7 @@ PLIST_FILES= ${U_BOOT_DIR}/u-boot.img \
${U_BOOT_DIR}/README
MAKE_ARGS+= ARCH=arm \
+ CC=${CROSS_GCC} \
CROSS_COMPILE=arm-none-eabi-
do-configure: